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1 INTRODUCTION 

1.1 Guide to the user manual 

The manual is structured into sections describing configuration and use of MultiTrend in some of the 
most widely used applications. 

1.2 Abbreviations and definitions 

 
Term Explanation 
CM Corrosion Monitoring 
SM Sand Monitoring 
MT MultiTrend 
FBM FieldBus Master 
FSM The electric field signature method (also called The electrical fingerprint) 
FC FSM coefficient: New pin-pair measurement relative to Signature measurement 
FSM-IT Field Signature Method Inspection Tool 
MultiTrend A computer program for retrieval, processing and display of data from an FSM based 

instrument 
ppt Part per thousand:  0,1% 
RS-232 Serial communication standard.  
RS-485 Serial communication standard.  
Signature Baseline measurement used as initial reference for later readings 
Site A process area with FSM-IT installations 
LCA Local Corrosion Analysis  
WT Wall Thickness 
 

2 MAIN DATA 

2.1 Copyright & Licence Notice 

Your licence agreement with CorrOcean ASA, which is included with MultiTrend, specifies the 
permitted and prohibited uses of the product.  Any unauthorized duplication or use of MultiTrend is 
forbidden. 
 
Copyright © 1997-2004 by CorrOcean ASA Trondheim, Norway. 

2.2 MultiTrend Platform Requirements 

• Windows 98/NT SP6 and IE5 or better/NT2000 SP3/ XP SP1 
• Pentium CPU 600MHz, 64MB memory or better 
• At least 50MB free disk space 
• VGA Monitor and minimum 800 * 600 resolution graphics adapter 

RS232 serial port 
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3 TECHNICAL DESCRIPTION 
MultiTrend is a Microsoft Windows based program, which is used to manage and analyze corrosion, 
erosion and FSM data. MultiTrend can be used to configure and receive data directly from a variety 
of erosion/corrosion and FSM monitoring equipment such as SandLoggers and MultiLoggers, FSM 
Loggers, G4 FSM Stations.  MultiTrend also supports the MultiCorr portable instrument and the FSM 
IT portable instrument. 
 

3.1 Key Features  

• Configure the MultiCorr instrument.  Corrosion probes can be defined in the MultiTrend 
program and later be downloaded to configure the MultiCorr instrument with the correct tag 
names and parameters. 

• Transmit data from the MultiCorr for storage on a PC. 
• Control and download information from connected instruments and probes. 
• Analyse corrosion and erosion data by performing various trending - corrosion rate plots and 

average metal loss and metal loss rate plots.  
• Use the erosion data to calculate the sand rates and perform trending of sand rates and 

average sand production. 
• Handles ER, Sand, LPR, PT, Galvanic, Analogue and Weigth Loss Copupon probes. 
• Control and configure FSM station functions 
• Control and configure FSM IT Instrument functions 
• Retrieve FSM data from your FSM stations 
• Retrieve FSM data from your FSM IT installations 
• Process and examine the FSM data as trends in XY plots or as 3D surface plots 

 

3.2 Supported instruments 

• SandLog 
• MultiLog 
• MultiCorr 
• FSM Station G2 
• FSM Station G4 
• FSM IT Instrument 
• FSM Log 

 

4 PREPARATION AND INSTALLATION 

4.1 Installing MultiTrend 

The MultiTrend installation program will perform the necessary steps to install MultiTrend on the 
computer. To start the installation program insert the CD disk into your PC, and the installation 
program will should start automatically, if the start automatically windows feature is disabled for your 
computer then start the SETUP.EXE program and follow the instructions given.  During the install 
process, you will be asked to submit the MultiTrend License number.  This license number is 
stamped either on the CD cover or on a separate sheet of paper.  The license number is necessary in 
order to enable the ordered functions of MultiTrend.   
 
To start a program using the Run command: 
 

1) Click the Start button, and then click Run. 
2) In the Open box, type the location and name of the program you want to start the Setup.exe 
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The user must input the directory location for the MultiTrend program and into which folder to put the 
program icons. 
 
An installation consists of a number of files of which some are installed in the program directory 
location and some are located in the Windows system directory.  In addition, the installation program 
will perform the necessary changes in the Windows Registry. 

4.2 Uninstalling MultiTrend 

To completely uninstall the MultiTrend program, display the Windows Control Panel and double click 
on the Add/Remove Programs icon.  In the Add/Remove dialogue, select MultiTrend and click the 
Add/Remove button to start the uninstall process.  The uninstall process will only remove program 
components. Data files will remain on the hard disk and must be removed manually by using the 
Windows Explorer. 
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5 OPERATING INSTRUCTIONS 

5.1 A Tour of the MultiTrend User Interface 

Title Bar
Pull Down
Menu Bar

Summary Window.
Select an item here
to bring up its detail
window in the right

pane

Log Window. Shows
information and error

messages

Detail Window. Shows
details about the item
selected in the
Summary Window

Mode Indicator

Resize Handle

Resize Bars

Right click in this
window to bring up
the context menu.

The menu contains
functions that can be

performed on the
item under the

pointer

 
 
Figure 11 The MultiTrend Main Window 

 
Figure 11 shows the main MultiTrend Window. The main components of the window are: 
 

• The Title Bar. The bar at the top of the window. The left part of the bar displays the current 
configuration filename (here Blake.mcf) and the Program name (MultiTrend). The right part 
of the bar contains icons for minimizing/maximizing and closing the window. 

• Below the title bar is the main drop down menu bar. Many common functions can be 
accessed via menus available here. Below the menu are the three view selection tabs. This 
part of the main window is hereafter called the summary window. This is used to select how 
the configuration data is presented. The options are: 

- General view. Gives information about how probes are located in context with larger 
structures (Figure 22 The General View) 

- Instrument View. Gives information about how MultiTrend communicates with the 
probes. (Figure 33 The Instrument View) 

- Status view. Presents the current status of the probes. (Figure 44 The Status View) 
• To the right of the summary window is the detail window. This window displays details about 

the item that is selected in the summary window. 
• Below the summary window is the log window. Error and information messages are displayed 

here. 
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The general view is

focused on visualisng
where the data

originates in a larger
structure

This symbol
indicates a large
structure

This symbol
indicates a measure
location on that
structure

Data from the
measure location is
stored under the
various probe
symbols

Click plus sign to
reveal sub items.

Click - signs to hide
sub items

 
Figure 22 The General View 

 
The instrument view

is focused on
visualizing the

instruments and their
connections

This symbol
indicates a subsea
sensor. It is
connected to an
interface which
indicates the
communication
channel (in this case
Modbus). MultiTrend
receives data from
the instrument via the
indicated interface
and stores it under
the indicated probes.

Interface symbols are
connected to the PC
symbols to indicate

how the instruments
are physically

connected to the PC

Data from the
instrument is stored

under the probe
symbols

 
Figure 33 The Instrument View 

The status view
presents the latest
measurement results
and the latest status

The status from the
last communication/
calculation is shown

here

This is the date and
time of the last
successful
measurement

Results selected in
the probes detail
window Calculation
tab are displayed
here

The unit can be
selected in the
Calculation tab  

Figure 44 The Status View 

5.2 A brief description of MultiTrend configuration items 

MultiTrend uses five classes of configuration items. These are: 
 

• Probes 
All measurement data are stored under various types of probes. The probe controls the 
calculation from raw data to result data. All calculation parameters are stored with the probe. 
Selecting it in the summary window accesses results and parameters for a particular probe. 

• Locations 
Only one type of location is used. It is used to group probes that are located together. 
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Sand probes use probes from the same location as inputs for sand calculation. The location 
symbol is only displayed in the General View. 

• Systems 
Only one type of system is used. It is used only to group items in the General View to make it 
easier to locate a particular probe in larger structures. 

• Instruments 
The instruments control data acquisition from the measuring devices. Instruments are only 
displayed in the Instrument View. 

• Interfaces 
The interfaces describe the communication channels between the sand computer running 
MultiTrend and the physical sensing device. Interfaces are only displayed in the Instrument 
View. 

5.2.1 The Sand Probe 

The sand probe is indicated by the  symbol. The sand probe has a number of metal elements that 
erode if exposed to sand particles. This makes the elements thinner, and their electrical resistance 
increases. The sand sensor measures the resistances and MultiTrend retrieves and stores these 
values. Based on the resistance values, MultiTrend calculates the following values: 
 

• Metal Loss 
This is the thickness of the metal that is eroded from the sand probe since the probe was new. 

• Erosion rate 
This is the rate the metal elements are diminishing in thickness. The rate is based on the 
average change of the latest metal loss values. The number of values used for the calculation is 
controlled by the F>> button next to the metal loss rate in the sand probes calculation tab. 

• Sand rate 
This is the calculated amount of sand per time unit. The calculation is based on the Erosion rate, 
the velocity of the medium carrying the sand and the average particle size of the sand. The 
velocities and particle size are taken from the flow and particle size probe in the same location 
as the sand probe. 

• Accumulated sand 
This is the amount of sand produced over a period of time and can only be plotted. 

• Sand content 
This is the amount of sand per volume unit of the medium. 

5.2.2 The flow probe 

The flow probe is indicated by the  symbol. The flow probe stores the oil, water and gas flow rates 
in the pipe in which the sand probe is mounted. These values are input manually if they are not 
available from a sensing device. From the rates, it calculates the velocity of the medium flowing in 
the pipe for use in sand calculations. It uses pipe diameter, pressure and temperature from the 
location as inputs for the calculation. 

5.2.3 The particle size probe 

The particle size probe is indicated by the  symbol. It is used to store the average size of sand 
particles for use in sand calculations.  Usually the data is manually entered. 

5.2.4 The pressure / temperature probe 

The pressure/temperature probe is indicated by the  symbol. It stores pressure and temperature 
readings from the sensing device or from manual input if no such device exists.  Pressure and 
Temperature is used by the sand and flow probe on the same location for sand and velocity 
calculations. 
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5.2.5 The FSM matrix probe 

The FSM matrix probe is indicated by the  symbol. It stores pair measurement for FSM matrixes.  
 

5.3 MultiTrend Status System 

MultiTrend has a system that gives information about status for all configuration items 
(Instrument, probes interfaces), each configuration item will have several status states that are 
displayed and optionally exported:  
The status is displayed in the General View and Instrument View visually as a yellow or red dot 
next to the item icon. Red indicates an alarm, yellow indicates warnings. 
 
Detailed information about the alarms is found in the details window for the item Figure 55.  
 

 
Figure 55 Status Details Window 

 
In the Details window three-text fields display the status, present action and the time and date 
for the last update for the item. For further information for the present alarm setting click, the 
status icon  or .  
 
In the Alarm Dialog Figure 66, the following is shown: 

• Tree view displaying the items involved in the status chain 
• Alarm Description showing a explanation about the alarm and the time stamp it 

appeared 
• With the drop down list the alarms and warnings can be triggered manually for test 

purposes 
• Clear alarm buttons 

 

 
Figure 66 Alarms Dialog 

 
 
 



CorrOcean ASA 
MULTITREND USER MANUAL 
Document No.: 4174-16959-I-MU-0003 

Rev:  04 
Page:  12 of  125 
Date:  03.10.04 

 
 

5.3.1 Status Types 

• Monitoring. The result of a calculation compared to a user defined set of limits 
(Optional): 

o High (The last result is above the limit) 
o Low (The last result is below the limit) 
o High over time (The result has been above the limit for set time) 
o Low over time (The result has been below the limit for set time) 
o Not updated over time (The result has not been updated for a set time) 
o Not changed over time (The result has not been changed for a set time) 

 
• Instrumentation. Any errors reported by the instrument hardware related to the 

instrument electronics or sensing device. Will have to be defined for each instrument 
type. Examples: 

o Element failure (maps to probe sub-item) 
o Low battery 
o Loss of charging current 
o Open pair maps to matrix sub-item 

 
• Communication Status. Result from last communication attempt 

o Error code 
 

• Unknown Status. When MultiTrend enters online mode, the instrumentation status must 
be considered unknown. For symmetry, all other alarms are cleared and the unknown 
alarm set. The unknown alarm is cleared at first alarm evaluation for the item (e.g. 
communication or new measurement events). 
 

• Action/Progress status. 
o Any time consuming action, usually communication progress. 
o Always cleared when done 

 

5.3.2 Status propagation rules 

The idea behind this is that the general view items displays the collective status of its child items. To 
achieve this, the status must propagate between items. 
  
The status propagates towards the child items in the instrument view and towards the root in the 
general view. The general view always display the "worst" status of its sub items. The instrument 
view displays the "worst" status of the parent items.  

5.3.3 Alarms and Warnings 

Each probe, instrument and system item in MultiTrend has an Alarms signal. This signal contains 
information about measurements exceeding set limits, instrumentation failures, communication 
problems and system problems. The signal can be extracted for a single probe or instrument, or 
combined for a group of probes as grouped by the system or location icon in MultiTrend. The signal 
is reported as a 32 bit unsigned integer value were each bit has a predefined meaning and must be 
inspected individually. 
 
 
Bit Number Name Comment 
0 A_AboveLimit Set when measurement is above a preset limit 

Cleared when measurement becomes below limit 
again or when A_AboveLimitAlarm is set. 

1 A_BelowLimit Set when measurement is below a preset limit. 
Cleared when measurement becomes below limit 
again or when A_BelowLimitAlarm is set. 

2 A_AboveLimitAlarm Set when preset number of consecutive 
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measurement has been above preset limit. 
Cleared when measurement becomes below limit 
again. 

3 A_BelowLimitAlarm Set when preset number of consecutive 
measurement has been below preset limit. 
Cleared when measurement becomes above limit 
again. 

4 A_UpdateTimeOut Set when no new measurement has arrived within 
preset interval. 
Cleared when a new measurement arrive. 

5 A_NoChange Set if a preset number of consecutive measurement 
are equal. 
Cleared when the measurement change. 

6 A_LowHardDisk The system disk or database disk has below 10MB 
and below 15% free space. 
Cleared when enough free space is made available. 

7 A_FileError Set when write to online export file failed. 
Cleared when last write to online export file 
succeedes. 

8 A_AllElementsInvalid Set when all elements are invalid for a 
measurement. 
Cleared when at least one element is valid 
(Applies to SandProbe/Er probes only). 

9 A_SomeElementsInvalid Set when at least one element becomes invalid 
(resistance of element is outside of 0.1mOhm to 
1.0Ohm or element metalloss is less than –10% of 
element thickness or more than 70% of element 
thickness) 
Cleared when all elements are valid or invalid. 
(Applies to SandProbe/Er probes only). 

10 A_SandCalc_FlowTooLow Set when flow velocity is too low for sand 
calculation. 
Cleared when flow velocity is large enough for sand 
caclulation 
(Applies to Sand Probes with Sand Rate checked 
for status view) 

11 A_InvalidProbeData Set when the probe raw data is not within valid 
ranges. 

12 A_InvalidProbeInputData Set when and input probe gives results that are 
meaning less for further calculations E.g. flow data 
used by a sand probe is invalid  

13 A_InvalidTimestamp Set when a measurement with an invalid timestamp 
was received. 
Cleared when a measurement with valid timestamp 
is received. 

14 A_RetrieveFailure Set when Scheduled or manual retrieval of 
measurements from instrument failed for any 
reason. 
Cleared when Scheduled or manual retrieval 
succeeds. 

15 A_NoResponseFromInstrument Set when last command to an instrument gave no 
response. 
Cleared when instrument response is received. 
 

16 A_InstrumentReceivedIllegalCo
mmand 

Set when the instrument reports that it received and 
unacceptable command. Cleared when the 
instrument accepts a command. (Applies to some 
instruments only) 

17 A_InvalidResponseFromInstrum
ent 

Set if the response from the instrument is invalid. 
Cleared when the instrument responds with a valid 
response. 
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18 A_InvalidInstrumentData Set if the measurement data packet from an 

instrument is badly formatted or has a checksum 
failure. 
Cleared when a valid measurement datapacket is 
received from the instrument. 

19 A_ConnectionProblem Set when an instrument or interface failed to 
connect or open port for communication. 
Cleared when instrument or interface succeeded in 
connecting. 

20 A_NoResponseFromFieldBusM
aster 

Set when Fieldbus master is not responding 
Cleared when fieldbus master responds. 

21 A_CommunicationProblem Set when an unspecific communication problem 
occurs. 
Cleared when communication succeeds. 

22 A_EmergencyMode Logger is in emergency mode 
23 A_LowMemory Set when MultiTrend detects that the available 

(virtual) memory is low 
24 A_DatabaseError Set when MultiTrend fails or partially fails to store a 

measurement in the database. 
25 A_HousekeepingWarning Set in an instrument item when a warning is 

triggered in the housekeeping probe. 
26 A_ HousekeepingAlarm Set in an instrument item when an alarm is triggered 

in the housekeeping probe. 
27-30 Reserved for future use Reserved for future use 
31 A_Unknown Set for all items when MultiTrend enters online 

mode. This happens e.g. after an uncontrolled PC 
shutdown or configuration changes. The status for 
probes is set to unknown until new data arrives or 
an error occurs. The status for instruments is set to 
unknown until communication occurs.  

 

5.3.4 Monitoring. Setting Limits. 

MultiTrend can be configured to monitor incoming data and trig warning and alarms upon set 
conditions. 
 
To bring up the monitoring dialogue for a particular signal, select the M>> button as shown in the 
following figure. 
 

 
Figure 77 Bringing up the monitoring dialogue 

The monitoring dialogue (Figure 88 below) allows high and low limit to be defined for the selected 
signal. If the value for the signal is outside the limits interval, an out of limits warning is trigged on 
this probe. If the number of consecutive values outside the interval is above the set value, an out of 
limits alarm is trigged on the probe. 
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Figure 88 The monitoring dialogue 

The settings for update monitoring allows an alarm to be trigged (No change Alarm) if the value is not 
updated at the expected intervals. 
 
The Apply to All button will copy the settings to all signals of the same type belonging to a probe of 
the same type. 
 

5.4 Using MultiTrend with MultiCorr 

The MultiCorr is probably the most flexible and sophisticated hand held corrosion meter available. It 
is designed for direct interrogation of all types of corrosion probes, but can also be supplied as an 
autonomous data acquisition unit for continuous monitoring and for communication with the 
CorrOcean range of corrosion and sand loggers. For details on using the MultiCorr instrument, see 
the MutiCorr Manual. 
 
The instrument is software-controlled, fully menu driven and reads the probe at hand upon simple 
operator commands. The readings are displayed instantaneously, e.g. in mm, mils (accumulated 
material loss), mm/y or mpy (corrosion rate), mA and mV (galvanic current or potential) according to 
the operator’s selection. The readings are automatically stored in the high-capacity memory, along 
with probe/tag no, date and time, and can be redisplayed at any point in time. 
 
The instrument can be used for any ER, LPR or Galvanic probe simply by selecting the probe type 
from the menu and entering the electrode surface area (for LPR or Galvanic probes) or sensing 
element thickness (for ER probes). The meter can furthermore read potentials/voltage signals, and 
accordingly be used in cathodic protection to measure accurately the current output from shunted 
anodes, as well as reference electrode potentials. 
 
With the memory loaded with readings for the day, the week or the month, the MultiCorr can be 
plugged directly into your PC, where MultiTrend retrieves the data and provides powerful means of 
data management capabilities.  
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5.4.1 Creating a MultiTrend Configuration 

To create a clean configuration file, select File->New on the pull down menu. Give the new file a 
suitable name e.g. "MultiCorr Test" so that it can be easily recognized. 

5.4.1.1 Connecting a MultiCorr instrument to MultiTrend 
MultiCorr can only be connected to MultiTrend via the PC’s COM port. 

5.4.1.2 Creating an interface 
Select Edit->New->Interface from the pull down menu as shown in Figure 11 (or New->Interface from 
the context menu). 
 

 

 

 
Figure 99. Creating an interface 

This brings up the interface selection window, shown in Figure 1010. Select Serial, then press the 
Next> button. 
 

Select the type of
interface you want

Select Next to
proceed

 
Figure 1010 Interface selection window 

 

If your serial port is
not listed, you can

type it in here

Select the Finish
button to complete
the creation of the
interface

 
Figure 1111 Port Selection Window 

Now your Instrument View contains an icon representing the new serial interface (see Figure 2424) 
Select the icon and chose the setup tab in the detail window. Select the baud rate according to 
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MultiCorr’s documentation; alternatively check the instrument’s configured baud rate.  In most cases 
the other parameters can be left with their default values. 

5.4.1.3 Adding a MultiCorr Instrument 
To make measurements, an instrument with probes must be connected to the interface. 
Select New->Instrument from the Interface context menu, give the instrument a name (e.g. MC1), 
and select MultiCorr from the Type drop-down list. 
 

 

 
Figure 1212 Adding an instrument 

If the instrument is physically connected to the PC, we can now communicate with it. 
 
 

5.4.1.4 Adding a probe to the MultiCorr configuration 
 
To add a probe, select Edit->New->Probe on the pull down menu, select New->Probe from the 

context menu or select the  symbol from the toolbar). 
In this example we add an ER probe.  
 

  
Figure 1313 Opening The Probe Selection Window 

This brings up the probe selection window as shown in Figure 4242. 
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Figure 1414 The probe selection window 

5.4.1.5 ER Probe Parameter Setup 
Consult your sensor documentation to determine the number of elements and the Reference 
thickness your ER probe element has.  Enter it in the Window as shown below, and then select the 
Next button. The next window allows you to record additional information about the probe. These 
parameters are optional. 
 

  
Figure 1515 ER Probe Parameter Setup 

 
Enter the information for the type of ER probe you have in the ER Probe parameter window. If the 
probe type you have is not listed, use the General type. Then select the Next> button. The next 
window allows you to record additional information about the probe. These parameters are optional. 

5.4.2 Transmit Data from MultiCorr to MultiTrend 

To receive data from the MultiCorr, first Ensure that COM port settings are correct.   
Go to the Instrument View Window and select the instrument from which you want to transfer data, 
by placing the cursor on the instrument.  The MultiCorr to be downloaded should be listed as 
connected to a relevant COM port. 
 
Select Retrieve Data>> from the commands tab in the Instrument Detail Window. 
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Figure 1616 Retrieve data from MultiCorr (1) 

 

 
Figure 1717 Retrieve data from MultiCorr (2) 

Ensure that the probe information you wish to download is selected by clicking the check box to the 
left of each probe. 
 
The probe’s Store options can be selected by clicking the relevant check boxes. 
On the MultiCorr Instrument select: 
 

• Advanced mode 
• Transmit 
• Transmit 

 
Data is now being transferred to the PC.  
 
If a probe is defined in the instrument but not created in MultiTrend prior to the data transfer, 
MultiTrend can create the probe automatically. 
 
Transferred data has to be stored or discarded before you can leave the Retrieve Data Window. The 
Select/ Deselect function makes it possible to filter out or save only selected data.  If the MultiCorr 
has transmitted data from e.g. 10 different probes and only one probe is of interest, the appropriate 
probe can be selected now, before clicking the Store Selected button.  Only data from the selected 
probe will now be stored. 
  
NOTE 
Probes which have been auto created will contain default values for the probe parameters.  These 
values should be changed to reflect the correct values of the probes. 
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5.4.3 Transmit MultiTrend Configuration Information to MultiCorr 

The probe setup information contains information like tag numbers, initial probe thickness, probe type 
etc.  To use a MultiCorr instrument, this information must be defined in the MultiCorr as well.  This 
information can either be input manually on the MultiCorr or transmitted from MultiTrend. 
 
To transmit probe setup information from MultiTrend to the MultiCorr instrument, first connect the 
MultiCorr instrument to the PC, and ensure that COM port settings are correct.  The MultiCorr to be 
downloaded should be listed as connected to a relevant COM port. 
 
Then go to the Instrument View window and select the instrument to which you want to transfer data. 
Select the Commands tab and press Transmit Probes>>. 
 

 
Figure 1818 Transmit probes to MultiCorr (1) 

Tick the check box in front of the probes for which you want to transfer the setup. 
 

 
Figure 1919 Transmit probes to MultiCorr (2) 

On the MultiCorr instrument: 
 

• On MultiCorr MKI select: 
- Advanced mode 
- Acq. Setup 
- Inst/Edit Tag 
- Type the instrument pass code 
- Rec. From PC 

• On MultiCorr MKII select: 
- Advanced mode 
- Acq. Setup 
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- Load from PC 

 
Answer OK in MultiTrend to start transferring the probe setup data to MultiCorr. 
 
NOTE 
When data is transmitted to the MultiCorr instrument, the tag number/channel number sequence will 
be decided by the Probe Number given in the Address field in the MultiCorr dialogue.  All Probe 
Numbers for one probe type must be unique. A probe given an address of 5 will then be given the 
same channel number on the MultiCorr instrument. Probe numbering will start on 0 for each probe 
type. 
 

1st LPR probe starts
on probe number 0

1st ER probe starts
on probe number 0

The probe number will be used by
MultiCorr to identify the probe
after the probe setup has been
transferred.

Selecting the MultiCorr in the Instrument
View displays details about it in the detail
window

The probe number can be set to an any
number from 0 to 99 by clicking here

 
Figure 2020 The MultiCorr address tab shows the probe numbers of the probes 

The following precautions should therefore be taken before re-transmitting probe data to a MultiCorr 
that already contains tag numbers. 
 

• Make sure all readings in the MultiCorr have been cleared 
• Always transmit all probes of a probe type to the MultiCorr 

 
WARNING 
Please also note that MultiTrend supports tag numbers with a length of 20 characters, whereas 
MultiCorr only supports 10 characters.  MultiTrend will not limit the tag numbers to 10 characters, so 
it is the responsibility of the user to ensure that tag numbers have the correct length. 

5.5 MultiTrend MultiLog/SandLog Offline System 

This section describes use of MultiTrend offline system. 
In a MultiLog/Sandlog system, the MultiCorr unit can be used to “carry” the measurement data from 
the Logger to the PC running MultiTrend. MultiCorr is used in terminal mode for this operation. 
Data is dumped from the Logger to the MultiCorr terminal and then retrieved by MultiTrend.  
The procedure is very similar for MultiLog and SandLog – the difference mostly concerns the various 
probes that can be connected to each of the loggers. In the following example, we will use a 
SandLogger instrument with a sand probe. Set up of the logger itself must be done from the MultiCorr 
instrument, please see the MultiCorr manual for this operation. 
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5.5.1 Creating a MultiTrend Configuration 

To create a clean configuration file, select File->New on the pull down menu. Give the new file a 
suitable name e.g. "Log Test" so that it can be easily recognized. 

5.5.1.1 Creating an interface 
Select Edit->New->Interface from the pull down menu as shown in Figure 2121(or New->Interface 
from the context menu). 
 

 

 

 
Figure 2121 Creating an interface 

This brings up the interface selection window, shown in Figure 2222. Select serial and press the  
Next> button. 
 

Select the type of
interface you want

Select Next to
proceed

 
Figure 2222 Interface selection window 
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If your serial port is
not listed, you can

type it in here

Select the Finish
button to complete
the creation of the
interface

 
Figure 2323 Port Selection Window 

Now your Instrument View contains an icon representing the new serial interface (see Figure 2424) 
Select the icon and chose the setup tab in the detail window. Select the baud-rate according to 
instrument documentation. In most cases the other parameters can be left with their default values. 
 

Select the new
interface to display

its detail window

Select the setup tab
to display the serial
port settings

Select baudrate
according to
sensor
documentation

 
Figure 2424 Setting Serial Port properties 

5.5.2 Connecting a MultiCorr Terminal to MultiTrend 

From the context menu of the Serial Com interface, select New->Interface. 
For type of interface, select Terminal under CorrOcean Interfaces, as shown in Figure 2525. 
 

 

 
Figure 2525 Creating a MultiCorr Terminal Interface 
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Give the terminal interface an appropriate name. 
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5.5.3 Adding a Logger Instrument and probe manually 

From the context menu of the Terminal interface, select New->Instrument 
Choose the wanted instrument. In this example, we select the SandLog. Give the instrument an 
appropriate name in the Tag field. 
 
 

 

Figure 2626 Adding an instrument 

5.5.3.1 Adding a probe to the MultiTrend configuration 
To add a probe, select Edit->New->Probe on the pull down menu (or select New->Probe from the 

context menu or select the  symbol from the toolbar). In this example, we add a sand probe see 
Figure 2727. 
 

 

 

Figure 2727 Adding a Sand Probe 

Give the probe an appropriate name. 
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5.5.3.2 Sand Probe Parameter Setup 
Consult your sensor documentation to determine the number of elements and the Reference 
thickness your sensors sand probe has.  Enter it in the Window as shown below, and then select the 
Next> button. The next window allows you to record additional information about the probe. These 
parameters are optional. See Figure 2828 
 

  

Figure 2828 Sand Probe Setup 

5.5.3.3 Sand Offline System 
The offline sand system set up is shown in Figure 2929.  
 

 
Figure 2929 Offline System 

5.5.4 Automatic creation of logger and probes 

If no MultiLog / probes have been defined under the Terminal, MultiTrend will create the correct 
probes and connect them to the MultiCorr Terminal when retrival of data is performed as described in 
5.5.5. The user must give each probe an individual tag name. The MultiCorr Terminal interface must 
still be created manually before retrieving data. 
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5.5.5 Retrieving data from MultiCorr Terminal 

Select the new MultiCorr Terminal icon; choose the Commands tab in the Detail pane and press  
Retrieve Measurements>>. After creation of probes, the Retrieve data from Terminal dialog appears. 
 

(1)

(2)

 
Figure 3030 Retrieve data from Terminal 

Select the probes to retrieve data from (1), and press Store Selected (2). 
Logger data will be retrieved from the MultiCorr Terminal. 
 

5.6 MultiTrend MultiLog/SandLog Online system 

This section describes setup of MultiTrend online system using a CorrOcean FieldBus system. 
The procedure is very similar for MultiLog and SandLog – the difference mostly concerns the various 
probes that can be connected to each of the loggers. In the following example we will use a MultiLog 
instrument with an ER probe  

5.6.1 Creating a MultiTrend configuration file 

To create a clean configuration file, select File->New on the pull down menu. Give the new file a 
suitable name e.g. "FieldBus Test" so that it can be easily recognized. 

5.6.2 Connecting a FieldBus system to the PC 

This step depends on the type of interface of the FieldBus system. Check the FieldBus Master 
documentation before proceeding. 
The example assumes that the communication between the PC and the FieldBus Master is through 
the PC COM port.  A MultiLog and a probe will be connected to the FieldBus Master. 
A brief description of adding a Modbus interface is also included. 

5.6.2.1 Adding a Serial Com Interface 
For connection via the PCs COM port, MultiTrend must be configured with a serial interface.  
Select Edit->New->Interface from the pull down menu as shown in Figure 3131 (or New->Interface 
from the context menu). If the sensor has a Modbus interface, you should proceed with section 
5.6.2.2. 
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Figure 3131 Creating an interface 

 
This brings up the interface selection window, shown in Figure 3232. Select Serial and press the 
Next> button. 
 

Select the type of
interface you want

Select Next to
proceed

 
Figure 3232 Interface selection window 

 

If your serial port is
not listed, you can

type it in here

Select the Finish
button to complete
the creation of the
interface

 
Figure 3333 Port Configuration Window 

Now your Instrument View contains an icon representing the new serial interface (see Figure 3434). 
Select the icon and chose the setup tab in the detail window. Select the baud-rate according to 
sensor documentation. In most cases the other parameters can be left with their default values. 
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Select the new
interface to display

its detail window

Select The setup tab
to display the serial
port settings

Select baudrate
according to sensor
documentation

 
Figure 3434 Setting the serial port properties 

5.6.2.2 Adding a Modbus interface 
If the FieldBus Master has a Modbus interface, MultiTrend must be configured with a Modbus 
interface. Please refer to the MultiTrend Modbus User Manual for a description of how to do this. If 
the FieldBus Master has a RS232 interface, this step should be skipped. 

5.6.2.3 Adding a FieldBus Master 
To add a FieldBus Master, select Edit->New->Interface from the pull down menu (or select  
New->Interface from the context menu).  This brings up the interface selection window as shown in 
Figure 3535. Chose the FieldBus Master under CorrOcean Interfaces. 
 

 
Figure 3535 The Interface Selection Window 

Give the interface an appropriate name, e.g. FBM1. 
If the FieldBus Master has been given a proper tag in the overall system, we recommend that this is 
used to identify the Master in MultiTrend. 
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5.6.2.4 Adding a FieldBus Segment to the Master 
A FieldBus segment must be added to the Master. The Fieldbus segment is the interface card 
installed in the FBM. Select New->Interface from the context menu, and select FieldBus Segment 
under CorrOcean Interfaces. One segment should be defined for each interface card. The Instrument 
View should now resemble Figure 3636. 
 

 
Figure 3636 FielBus Master and Segment 

5.6.3 Adding a Logger Instrument and Probe 

To make measurements, an instrument with probes must be connected to the FieldBus system. 
Select New->Instrument from the FieldBus Segment context menu, give the instrument a name (e.g. 
ML1),  In this example we select MultiLog from the Type drop-down list. 
 

 

 
Figure 3737 Adding an instrument 

If the hardware (Master and Logger) is physically connected to the PC, we can now communicate 
with the logger. 
To determine the logger’s address, select the Address tab in the Detail pane and set the address to 
255 (broadcast) (makes the Master communicate with all connected loggers). Only one logger can be 
connected at a time, when broadcast is used for identifying a logger. 
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Figure 3838 Determining logger address 

Select Status Details and click Refresh!, as shown in Figure 3939. 
 

Select Status Details

 
Figure 3939 Communicating with the Logger 

If the communication is set up properly, the logger should now give its status. 
 
The logger address can be read out of the SW Version string in the Status Details window, as shown 
in Figure 4040. 
 

3.08-001-CAL-001    -IJKLM

AddressIDSW
Version

Enabled
Probes

Cali-
brated

 
Figure 4040 Logger ID and address 

Alternatively, the logger address can be queried by using an Interactive Logger Command, see 5.6.6. 
Set the correct logger address in the Address tab to avoid conflicts with other loggers. The Logger 
address can be set from 2 to 31. Address 1 is used for the Field Bus Master. 
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5.6.4 Troubleshooting Logger Communication 

If the procedure in section 5.6.2 gives no response in the logger Status window, these are the most 
common causes. 

• The MultiTrend serial interface has been set up with wrong baud rate. 
• The RS232 cable and/or cable between logger and FieldBus Master are not properly 

connected.  (If the two green data LEDs on the FieldBus Master are flicking when trying to 
communicate, the communication between PC and Master is functioning properly). 

• The logger’s battery is discharged. Try leaving the logger connected for about half an hour 
and try communicating again. 

 
If all these checks fail to produce a response, the logger may be faulty. Please contact CorrOcean for 
further support. 

5.6.5 Retrieving Measurements using a FieldBus / Logger system 

This step assumes that a Logger and a FieldBus interface have been added to the MultiTrend 
configuration. 
 
All measurements stored by MultiTrend are associated with a probe. Before measurements from the 
logger can be stored, the probes must be added to the configuration.  

5.6.5.1 Adding a probe to the MultiTrend configuration 
To add a probe, select Edit->New->Probe on the pull down menu (or select New->Probe from the 

context menu or select the  symbol from the toolbar). 
In this example, we add an ER probe.  
 

  

Figure 4141 Opening the Probe Selection Window 

This brings up the probe selection window as shown in Figure 4242. 
 

 
Figure 4242 The probe selection window 
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5.6.5.2 Probe Parameter Setup 
Consult your sensor documentation to determine the number of elements and the Reference 
thickness your probe has.  Enter it in the Window as shown below, and then select the Next> button. 
The next window allows you to record additional information about the probe. These parameters are 
optional. 
 

  
Figure 4343 ER Probe Parameter Setup 

Consult your sensor documentation to determine the type of probe you have. Enter the information in 
the Probe parameter window. If the probe type you have is not listed, use the General type (Only for 
ER Probes). Then select the Next> button. The next window allows you to record additional 
information about the probe. These parameters are optional. 

5.6.5.3 Probe setup verification 
When you have added all sensors with probes to be tested, your Instrument View should look 
something like Figure 4444. 
 

MultiLog with probe
has been added to
FBM1 on Field Bus
Segment

Icons can be
dragged and dropped
to connect/deconnect

ER Probe is
displayed as

connected to ML1

 
Figure 4444 Instrument View after adding logger and probes 

5.6.5.4 Taking single measurements 
The MultiLog can store up to 3000 buffers containing measurements.  Maximum number of 
measurements depends on the type of probe used. 
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To make sure there are measurements in the buffers, we now would like to instruct the logger to take 
measurements at a specified interval. 
 
First, we want to synchronise the logger’s clock with our PC’s internal clock. 
From the Commands tab press Synchronise Now!. 
In Instrument View select the MultiLog, select the Commands tab and click the Change button under 
the Measure group. In the dialog that pops up, you can set the logger’s measuring interval (See 
Figure 4545).   For test purposes, set the Measure Every x [interval] to 2 minutes. 
Press OK.  MultiTrend will now send this setup to the logger. 
Communication status messages are shown in MultiTrend’s log window. 
 

 

 

Figure 4545 Setting logger intervals 

To ensure that the logger has taken measurements, wait a few minutes before proceeding. 
Select Refresh from the Status Details tab and check that the Used Buffers value is > 0. 
This indicates that the logger contains measurements. 
 
From the Commands tab of the logger, select Retrieve Now!.  MultiTrend will request the logger for 
any measurements stored in the measurement buffers.  If the buffers contain many measurements, 
this operation may take some time. 
 

 
Figure 4646 Retrieving measurements from the logger 

From the Probe Detail pane, the last measurement will be shown with timestamp and measured 
value. 
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Figure 4747 Retrieved probe measurements 

5.6.5.5 Retrieving measurements automatically 
 
As shown in the previous section, the MultiLog can be set up to take measurements at specified 
intervals.  MultiTrend can also be set up to retrieve these measurements. 
 
Figure 4848 shows a part off the panel in Figure 4747, which is used for setting automatic retrieval 
from a logger. 
 

Interval

Initial retrieve

Toggle automatic
retrieval on/off

 
Figure 4848 Automatic Retrieval setup 

Set an appropriate interval for retrieval, as well as Next Retrieval if needed, and toggle the ON/OFF 
button to ON. The time set in Next Retrieval will delay the first automatic reading until it reaches the 
time set. (i.e. the delay could be as much as 24 hours!) 
From the Mode menu, select Online to enable online mode. 
Automatic retrieval only works in online mode. 
 

 
Figure 4949 Entering Online Mode 

At next retrieval time, MultiTrend will connect to the logger and retrieve all measurements stored in 
the memory buffers. 
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5.6.6 Advanced Logger Setup 

For advanced logger setup, press Advanced Setup>> from the Commands tab Figure 4646. 
The Advanced Logger Setup dialog appears Figure 5050. 
The most widely used commands here are Clear Logger Memory After Retrieval (1) and Stop 
Retrieval After Failed Reset (2). 
 

(1) Clears the logger buffers for all measurements after retrieval.  If this is left unchecked, the 
logger buffers will eventually fill completely.  Consequently, the logger will stop logging 
(measuring). 

(2) If checked, a failed software reset of the logger will result in a halt of automatic retrievals. 
 

(2)

(1)

 
Figure 5050 Advanced Logger Setup 

 
Another set of manual (interactive) logger commands can be accessed by pressing  
Logger Configuration>> in the Commands tab Figure 4646. 
These commands are illustrated in Figure 5151. 
 

Forces the logger to
measure immediately
SW reset of the logger

Clears logger buffers

Set new logger
address

Get current address

 
Figure 5151 Interactive Logger Commands 

5.7 Operating Procedure for Topside Sand/Corrosion Management 

This section describes normal operation for a Topside Online Sand / Corrosion Management (CM) 
System. 
In this example we assume that the user has some prior knowledge of how to set up communication 
and probes in MultiTrend. 

5.7.1 Configuration 

As an example, we use a Combination Sand/ER-probe connected to a SandLog, interfacing to the 
PC’s Comport via a FieldBus system. 
For extensive information on how to set up a FieldBus system, see section 5.6.  
Offline probes Flow, Particle Size and pT are used for input to calculations. 
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NOTE 
In order to make the Flow, Particle Size, and pT probes act as input to calculations, these must be 
physically placed on the same location as the probes upon which the calculations are being done, in 
the general view. 
 
Figure 5252 shows the physical placement of the various probes using the General View.  All probes 
seem to be placed on the same location (Loc1).  The truth is that only the Combination Probe is 
physically placed on Loc1, the other probes are offline theoretical probes only used as input for 
calculations. 
The Combination Probe is shown as two separate probes, one ER-probe and one Sand probe. 
 

Offline probes for
calculation input

 
Figure 5252 General View 

 
Figure 5353 shows the logical connection of the probes using the Instrument View. 
The view on the right shows the probes connected to the logger. 
Note that the Connector field is equal for both Sn1 and Er1, indicating that this is a Sand/ER 
Combination probe. 
 

Offline probes for
calculation input

View of probes
connected to the

logger.

 
Figure 5353 Instrument View 

 
 
 
 
 



CorrOcean ASA 
MULTITREND USER MANUAL 
Document No.: 4174-16959-I-MU-0003 

Rev:  04 
Page:  38 of  125 
Date:  03.10.04 

 
Figure 5454 shows the Probe Status View.  This view is normally used for online operation of 
MultiTrend. 
 

 
Figure 5454 Probe Status View 

To display probe values in the Probe Status View, check the value’s checkbox in the probe’s 
Calculations view, as shown in Figure 5555. 
 

 
Figure 5555 Displaying probe values in Status View 

To enable Simple View, press the Simple View button on the toolbar, as shown in Figure 5656. 
 

Simple View button  
Figure 5656 Selecting Simple View 

Now MultiTrend will automatically receive measurements at the preset intervals. 
Selected probe values are displayed in Probe Status View, as shown in Figure 5757. 

 
Figure 5757 Viewing probe measurements 
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5.8 Using MultiTrend With CorrOcean SubSea Sensors 

 
This chapter describes the day-to-day operation of a CorrOcean SubSea Sand/Corrosion Monitoring 
system. 

5.8.1 General System Description 

The typical system consists of the following elements: 
 

• CorrOcean SubSea Sand Sensors 
The sensor consists of an electronic signal conditioning unit and an intrusive sand probe. The 
unit is mounted on the pipe as shown in Figure 5858. 

• SubSea Control Modules/ SubSea Electronic Module 
Each sand sensor is connected to a control module. The control module supplies power to 
the sand sensor. It also forwards communication between the sand sensor and the control 
system /DCS. 

• The control system / DCS 
Communicates with the SubSea Control Modules /SEMs. It receives the raw measurements 
from the sand sensor and forwards them to the sand computer. 

• The sand computer 
Receives raw sand sensor readings from the control system, computes engineering values 
and forwards them to the control system. 

 

DCS

Sand probeSignal Conditioning
unit (SCU)

RS 232

Interface with control system

PC

Topside
Control
Unit

Supplied by client

Manifold
Subsea
Electronic
Module
(SEM)

 
Figure 5858 Typical SubSea Sensor System 
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The sand computer has the following main software components: 

• The CorrOcean MultiTrend software 
This is the main software package that receives raw measurements, computes engineering 
values, and stores measurements. MultiTrend also has functionality for displaying, plotting 
and printing measurements. 

• The MultiTrend Configuration File 
This file contains all information MultiTrend needs to handle the measurements from the 
sensors. This includes tags, sensor types, probe types, calculation parameters and 
communication interface information. 

• The MultiTrend database file 
This file contains all stored measurements. 

• Interface Modules 
The exact interface modules vary from system to system, but their function is always to 
receive raw data from the control system and return processed data. The most common are: 
Modbus Interface Modules (MTModbus and CorrMod on systems up to version 2.26 and 
RegSigMap and CorrMod on later systems), STP Interface module (STPInterface), SQL 
Interface Module (SQLInterface) and OPC Interface Module (OPCInterface) 

• Interface Configuration files 
Configuration files for the interface modules. 

5.8.2 Example System description 

The following sections describe a typical sand monitoring system. 

5.8.2.1 MultiTrend configuration 
The General View shows the three templates L, M and N. It shows the four sensing locations on each 

template and the probes on each location. Only the sand probe  and pressure/temperature probe 

 are actual probes. The flow probe  and particle size probe  are virtual probes used to give 
additional input to sand calculations. Figure 5959 shows General view to the left and Instrument view 
to the right. 
 

These symbols
indicate the three
templates on
Example system

These symbols
indicate the sensing
locations on the
template
These symbols
indicate production
rates (oil, water and
gas) on the location.
Data is input
manually

These symbols
indicate hte average
particle size of the
sand produced.
Data is input
manually.

Indicates that the raw
values arrive via the
Modbus interface.

Pressure/Temp. data
is stored here.

Sand data is stored
here.

This symbol
indicates each of the
CorrOcean SubSea
sensors.

Clicking this symbol
will show or hide sub-
items.

Unconnected items
(flow rates and sand
particle size) must
get data input
manually.

 
Figure 5959 Example MultiTrend configuration 
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5.8.2.2 Modbus Interface 
The Modbus interface module consists of two extra programs that run on the sand computer. This is 
the CorrMod program that handles the Modbus communication and the RegSigMap program that 
makes data from the Modbus link available to MultiTrend and makes data from MultiTrend available 
for the Modbus link. 
 
NOTE 
For MultiTrend versions 2.26 and older, the RegSigMap was called MTModbus, and the user 
interfaces for MTModbus and CorrMod was slightly different from the current versions. 
 
When MultiTrend starts with a Modbus configuration, it will attempt to start the RegSigMap program, 
which in turn starts the CorrMod program. 
 
Figure 6161 shows the RegSigMap program. This program must be running to allow MultiTrend to 
communicate over Modbus. 
 
The CorrMod program displays itself in the system tray (the small area in the lower right part of the 
screen) as this a blinking red, green and blue symbol:  
 

 
Figure 6060 CorrMod System Tray icon 

By double clicking this symbol, the CorrMod programs user interface can be accessed as shown in 
Figure 6262. 
 

 
Figure 6161 The RegSigMap program User Interface 

 
Figure 6262 The CorrMod program User Interface 
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5.8.3 System Operation 

The normal operation of the system is fully automatic. The most common operator tasks are 
described in the following sections. 

5.8.3.1 Manual input of production parameters 
The sand rate, accumulated sand, and sand content results depend on the pressure, temperature, 
flow rates, average sand particle size and pipe diameter at the sand probes location. These 
parameters must be manually input whenever they change more than 10-20%. If this is not done, the 
sand calculations will come out with incorrect results. 
 
Figure 6363 and Figure 6464 shows how to enter the manual inputs. Pressure and Temperature 
inputs should not be changed since the combined sand/pressure/temperature sensor measures them. 
 

1)
Pipe diameter (inner)
will never change
significantly and can
be left constant.

3)
Select the Input
Production Data>>
button

2)
Select the location in
general view

 
Figure 6363 Manual input of production parameters (1) 

 
Enter date and time
for the change in
prodution.

Choose suitable units

Leave unchanged ,
since these are

measured by the
SubSea sensor.

Enter the average
particle size for the

produced sand.
 

Figure 6464 Manual input of production parameters (2) 

5.8.3.2 Verifying that the system is operational 
Some systems have an alarm set on the measurement timestamps. If the timestamps stops updating 
the alarm goes off. This indicates that something is wrong. 
 
If the control system has no such alarm, the easiest way to verify that the system is operational, is to 
check that the values received by the control system are changing. There is always a small amount 
of noise so the values should change slightly for every new measurement. 
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The same checks can be made on MultiTrend as shown in Figure 6565. 
 

These buttons change
the display mode
between Advanced view
Simple view

Values are updated as
new measurements
arrive

MultiTrend should normally be in Online
Mode.
Service Mode may be used to change
the configuration (should only be done by
experienced users).  

Figure 6565 Verifying that the system is operational 

 
It is also useful to verify that the Modbus interface is operational. 
Press Edit Mode in the CorrMod program, and select the Master icon.  Then select properties and 
enable logging. Close the properties window and select the log tab. You should now be able to see 
Modbus messages as they arrive from the Modbus master. 

5.8.3.3 Copying the database file for offline analysis 
It is often useful to extract data for offline analysis. This is done by copying the MultiTrend 
configuration file and the corresponding database file Figure 6666 shows how to locate the file. The 
database file can grow quite large over the years, so a compression utility and a high capacity 
medium must often be used to carry the file. 
 
See also 5.11.6 - Data Export and Import. 
 

In General View,
select the root item.

The Configuration's
file name is displayed
here.

 
Figure 6666 Locating the configuration and database files 
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5.8.3.4 Restarting the system 
There are two ways to restart the system: 

• Controlled shutdown and restart 
• Reboot and restart 

 
Controlled shutdown and restart: 

• Close all programs. MultiTrend must be in service mode to allow closing. 
• Make sure that no modules are running invisible in the background. Use the task manager 

and scan the process list for one of the following. 
- MultiTrend,  
- For systems with Modbus interface: MTModbus and CorrMod or RegSigMap for 

systems from v2.27 
- For systems with SQL interface:  SQLInterface 
- For systems with OPC interface: OPCInterface 
- For systems with STP interface: STPInterface 

• Close down the above-mentioned tasks if present. 
• Start MultiTrend from the Start menu or Desktop Icon 
• Make sure MultiTrend is in Online Mode 
• Make sure any interface modules has started 

5.8.3.5 Error messages and troubleshooting 
Below are presented some of the most common problems with MultiTrend / Modbus systems, along 
with their solutions: 
 

• No new data arriving at the control system 
Check if MultiTrend is running and data is received. If not check for error messages and see 
below. 

• No new data arriving in MultiTrend 
Check that it is in online mode. Check that the Modbus programs (RegSigMap and CorrMod) 
are running. Check for error messages and see below. 

• Various communications, timeout and response errors 
These indicate that the commands sent from MultiTrend to SubSea sensors receive no 
response. Check that the CorrMod program is receiving messages by enabling logging and 
watching the log. If no messages arrive, check the Modbus cabling and that the Modbus 
master (usually the Control System) is polling. If this is not the problem or if messages arrive, 
try to restart MultiTrend. If this does not help, contact CorrOcean customer support. 
support@corrocean.no 

• Various error messages 
Check the data values on the flow and particle size probe at the same location.  The values 
must be correct for sand calculations to work. 

5.9 Using MultiTrend To Test CorrOcean SubSea Sensors 

It is often useful to use MultiTrend to test CorrOcean SubSea sensors and sensor simulators. This 
allows easy management and documentation of test data. The following sections explain stepwise 
how to configure and operate MultiTrend during such a test. It is assumed that MultiTrend is already 
installed on the PC. 

5.9.1 Creating a MultiTrend Configuration File 

To create a clean configuration file, select File->New on the pull down menu. Give the new file a 
suitable name e.g. "SubseaSensorTest" so that it can be easily recognized. 

5.9.2 Connecting the Sensor to the PC 

This step depends on the type of interface the sensor has. Check the sensor documentation before 
proceeding. 
 

mailto:support@corrocean.no
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• If the sensor has a native CorrOcean protocol/RS485 interface, it must be connected to the 

PCs RS232 serial port via an RS232-RS485 converter. The Westermo MD44 is a robust 
converter that is recommended by CorrOcean. 

• If the sensor has a Modbus interface, it can be connected to the PCs serial port via an 
RS232-RS485 converter. 

• If the sensor has any other interface, special hardware and software may be required to test 
and operate the sensor. This manual cannot be applied. 

 

5.9.2.1 Adding a Serial Com. Interface 
If the sensor has a Native CorrOcean protocol/ RS485 interface, MultiTrend must be configured with 
a serial interface. Select Edit->New->Interface from the pull down menu as shown in Figure 6767 (or 
select 
New->Interface from the context menu). If the sensor has a Modbus interface, you should proceed 
with section 5.9.2.2. 
 

 

 

 
Figure 6767 Creating an interface 

This brings up the interface selection window, shown in Figure 6868 Select Serial and then press the 
Next> button. 
 

Select the type of
interface you want

Select Next to proceed  
Figure 6868 Interface selection window 
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If your serial port is
not listed, you can

type it in here

Select the Finish
button to complete
the creation of the
interface

 
Figure 6969 Port Configuration Window 

Now your Instrument View contains an icon representing the new serial interface (see Figure 7070) 
Select the icon and chose the setup tab in the detail window. Select the baud rate according to 
sensor documentation. In most cases the other parameters can be left with their default values. 
 

Select the new
interface to display

its detail window

Select The setup tab
to display the serial
port settings

Select baudrate
according to sensor
documentation

 
Figure 7070 Setting the serial port properties 

5.9.2.2 Adding a Modbus interface to the MultiTrend configuration 
If the sensor has a Modbus interface, MultiTrend must be configured with a Modbus interface. Please 
refer to the MultiTrend Modbus User Manual for a description of how to do this. If the sensor has, a 
Native CorrOcean protocol/ RS485 interface, this step is should be skipped. 

5.9.2.3 Adding a SubSea Sensor 
To add a SubSea sensor, select Edit->New->Instrument from the pull down menu, alternatively select 

the  button in the toolbar, or select the New->Instrument from the context menu. This brings up 
the instrument creation window as show in Figure 7171.  Enter a tag ID that makes it the sensor easy 
to identify.  If the sensor has been given a proper tag in the overall system, we recommend that it is 
used. Choose the SubSea instrument type.  The other fields are optional.  Click the OK button when 
you are done.  A small blue icon should now appear in the Instrument View.  If it is not connected to 
the serial interface as shown in Figure 7272, drag & drop it on the COM1 icon to connect. 
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Enter a unique tag name

Name field
(optional)

Additional fields
(optional)

Description field
(optional)

Select sensor
type

 
Figure 7171 The Instrument Selection Window 

5.9.2.4 Verifying the Native Sensor ID and Sensor Communication 

Select the Subsea
Sensor Icon to

display the sesors
detail window

Select the
commands tab to
display the sensors
command window

Select the advanced
setup button to
open the advanced
setup window

Select the Instrument
View to display the

instruments and
interface connections

The tag can be
changed by selecting
this button

The sensor icon is
connected to the

serial interface.

 
Figure 7272 Opening the SubSea instrument advanced setup window 

Bring up the Advanced Instrument Setup windowFigure 7272 by selecting the Advanced Instrument 
Setup>> button. You should now be able to send commands to the sensor and receive responses 
from it. 
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Select a Data Format
that corresponds with
the sensor setup

 
Figure 7373 Data Format Selection 

Data Format should be selected to correspond with the senor setup. Consult your sensor 
documentation to determine this. 
 
NOTE 
If you have a sensor that is configured to automatically output measurements at preset intervals, you 
should not try to send commands to it. Please consult your sensor documentation to determine this. If 
you have such a sensor, the response window will receive data from the sensor at regular intervals. 
 
WARNING 
Do not send random commands to the sensor. This may change the sensors configuration 
permanently. No commands that change the sensors configuration should be sent to sensors located 
SubSea. 
 
Select the hex radio button in Figure 7474 and send the following 3-letter command to the sensor: 
#01 
The response is an echo of the command, but with the second byte replaced by the sensor ID. 
Subtract 30(hex) from the byte value to determine the id. This ID is also documented in the sensor 
documentation. It is not necessarily the same as the serial number. 
 

Type the command
here.

Select the send
button to send the
command

Select Hex to display
the response in
Hexadecimal
numbers

Subtract 30(hex)
from the second
response byte to

determine the native
ID of the sensor.  

Figure 7474 Sending a command to the sensor to determine its native ID 
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5.9.3 Troubleshooting SubSea sensor communication 

If performing the procedure in section 5.9.2.3 gives no response from the sensor in the Response 
window, these are the most common causes. 

• The MultiTrend serial interface has been set up with wrong baud rate. 
• The RS232-RS485 converter has been configured with wrong baud-rate 
• The RS232-RS485 converters connection to the PC is faulty. Check if the TX and RX lines 

are correctly connected. 
• Some RS232-RS485 converters require extra hardware flow control lines such as RTS and 

CTS. Check this in the converter documentation. In this case, MultiTrend must be configured 
to control those lines. The cable between the converter and the PC must have connections 
for these signals. The Westermo MD22 converter does not use hardware flow control. 

• The sensor has no power. Use a voltmeter to verify that the sensor has power or if it is a 
simulator, inspect its power indicator LED. 

• Some of the sensor connections have been mixed up. Check all four connections against 
documentation. 

• If SubSea cables/jumpers are connected, the connectors or cables may be faulty. Try to 
connect directly without any SubSea cables/jumpers. 

• The converter outputs have been mixed up. Some Westermo converter have mixed up 
labels on the converter outputs. Try to swap the lines. 

• The converter has wrong termination resistance on the RS485 lines. 
• The sensor has somehow lost its baud rate setting. Try to change the baud rate to 1200, 

9600 and 19200 baud in MultiTrend and on the converter. If the baud rate is wrong, contact 
CorrOcean for instructions on how to reset it to the specified rate.  
 

Warning 
In any circumstance, do not try to change the baud rate on sensors located SubSea, even if 
you know how! 
 
If all these checks fail to produce a response, the sensor may be faulty. Please contact CorrOcean 
for further support. 

5.9.4 Setting Correct Sensor ID in the MultiTrend Configuration 

Enter the ID found in the sensor documentation or in step 5.9.2.4 as shown below. 
 

Select The sensor for
which you want to

change the id/
address

Select The address tab
to display

Enter the correct ID
here

 
Figure 7575 Changing Sensor ID 
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5.9.5 Collecting Test Measurements from SubSea Sensors 

This step assumes that a SubSea sensor and interface have been added to the MultiTrend 
configuration. 
 
All measurements stored by MultiTrend are associated with a probe. Before measurements from the 
SubSea sensor can be stored, the probes must be added to the configuration. SubSea sensors come 
with several types of probes: 

• Sand probe 
• ER Probe 
• Combined Sand/ER Probe 
• Pressure/Temperature Probe 
• Combined Sand/Pressure/Temperature Probe 

5.9.5.1 Adding a probe to the MultiTrend configuration 
To add a probe, select Edit->New->Probe on the pull down menu, select New->Probe from the 

context menu or select the  symbol from the toolbar.  
 

 
 

Figure 7676 Opening The Probe Selection Window 

This brings up the probe selection window as shown in Figure 7777. 
 

 
Figure 7777 The Probe Selection Window 

Enter a suitable tag. Since the SubSea sensor and its probes are one unit (sometimes called the 
SubSea Probe Assembly or SPA) it usually has a single tag name. We have already used this tag 
and must therefore make a new one e.g. by adding the probe type to the sensor tag. If the SubSea 
sensor tag is XYZ, the ER probe tag becomes XYZ-ER. Select the type of probe you have (consult 
the sensor documentation if necessary). If you have a combined probe, chose one of the probes from 
the combination, then repeat this step for the other probe in the combination. The other fields are 
optional. Select the Next> button when you are done. 
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The next section will vary depending on the probe type: 

5.9.5.2 Sand Probe Parameter Setup 
Consult your sensor documentation to determine the number of elements and the Reference 
thickness your sensors sand probe has.  Enter it in the field as shown in Figure 7878, and then select 
the Next button. The next window allows you to record additional information about the probe. These 
parameters are optional. 
 

 
Figure 7878 Sand Probe Parameters 

5.9.5.3 Er Probe Parameter Setup 
Consult your sensor documentation to determine the type of ER probe you have. Enter the 
information in the ER Probe parameter window. If the probe type you have is not listed, use the 
General type. Then select the Next button. The next window allows you to record additional 
information about the probe. These parameters are optional. 
 

 
Figure 7979 ER Probe Parameters 

5.9.5.4 Pressure/Temperature Probe Parameter Set-up 
For newer SenCorr systems the calculations are done in the instrument choose the SenCorr PT 
option. The MultiTrend calibration option is kept for backwards compability and test purposes. 
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Figure 8080 pT Probe Parameters 

When using the MultiTrend calibration check the PreSens checkbox and select the PreSens 
Parameters button this bring up the PreSens parameter window as shown in Figure 8181. The 
PreSens certificate that comes with the sensor contains all the parameters to be entered here. Enter 
the parameter threshold found on the certificate. If you have the certificate in electronic format, you 
can use MS Excel to cut & paste the parameters into MultiTrend. Select the OK button and then 
select the Next> button. The next window allows you to record additional information about the probe. 
These parameters are optional. Number of parameter sets must be chosen to match the certificate. 
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Figure 8181 PreSens Parameters 

Parameter Course Accurate Comment
a03-b092 T=-20C to 20C T=20C to 80C
a1 -6.80201703E-09 -2.06480369E-10 bar / °C / (mV/V)^3
a0 1.07458786E-05 1.05714147E-05 bar / (mV/V)^3
b1 -1.07753160E-05 -1.09558580E-05 bar / °C / (mV/V)^2
b0 1.62317966E-03 1.62873486E-03 bar / (mV/V)^2
c2 4.13213980E-06 5.31161729E-06 bar / °C^2 / (mV/V)
c1 1.30981651E-02 1.29908554E-02 bar / °C / (mV/V)
c0 6.38736090E+00 6.38884336E+00 bar / (mV/V)
d2 -1.49870908E-04 -6.13432244E-05 bar / °C^2
d1 -5.07551509E-02 -5.70326539E-02 bar / °C
d0 1.05175701E+01 1.06077120E+01 bar
e1 -4.34105105E-07 -3.04387268E-07 Ω / °C / bar^2
e0 1.17830547E-04 1.14379179E-04 Ω / bar^2
f1 5.95773693E-05 -3.25263777E-07 Ω / °C / bar
f0 -1.28554375E-01 -1.26937394E-01 Ω / bar
g3 1.85204908E-07 1.29150363E-08 °C / Ω^3 
g2 -3.49251223E-03 -2.74250587E-04 °C / Ω^2
g1 2.20415703E+01 2.00501439E+00 °C / Ω
g0 -4.65255422E+04 -4.94734669E+03 °C

 
 
Figure 8282 Facsimile from a PreSens certificate 

5.9.5.5 Probe setup verification 
When you have added all sensors with probes to be tested, your Instrument View should look 
something like Figure 8383. 
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All sensors to be
tested have been

added with the
correct probes.

Make sure the
sensors have been

connected to the
interface icon

Make sure the
probes have been

connected to the
sensor icon

Icons can be
dragged&dropped to
change connections

Combined Sand/ER probes should
have the sand probe as Probe 1. This
can be changed by temporary dragging
away one of the probes placing it on the
"unconnected icon and then select
probe number here

 
Figure 8383 Instrument View after adding sensors and probes 

5.9.5.6 Taking single measurements 
Select the sensor you are testing, select the Commands tab and click the Retrieve Now! button as 
shown in Figure 8484. A window comes up, indicating that a command is in progress. Messages 
about the progress of the command are shown in the message log. 
 
NOTE 
If your sensor is configured to automatically transmit measurements at preset intervals, caution 
should be taken when requesting measurements. 
Please consult the Sensor documentation. 
 

Select the probe you
are testing here

Select the
Commands tab to

display the Sensor
Command Widow

Messages about the
progress of the
command are
displayed here

 
Figure 8484 Taking a single reading from a SubSea sensor 
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5.9.5.7 Taking multiple measurements 
 
There are two different ways of taking multiple measurements: 
 

(1) Instrument Initiated Measure 
(2) MultiTrend Initiated Measure 

 
When using (1) Instrument Initiated Measure, the measure interval is set as shown in Figure 8585. 
 

 
Figure 8585 Instrument Initiated Measure 

After selecting an appropriate interval, press Send Setup to Instrument. 
The SubSea Sensor will now control the measurements, and MultiTrend will receive measurements if 
it is in Online Mode. 
 
When using (2) MultiTrend Initiated Measure, the measure interval, as well as initial measure is set 
by the user and managed by MultiTrend. 
Delay between measure and retrieve command x seconds indicates the delay between measure 
command to the Sensor, and the following retrieve command. 
See Figure 8686. 
 

 
Figure 8686 MultiTrend Initiated Measure 

NOTE 
Choice (1) and (2) cannot both be set at the same time. 

5.9.6 Online Data Export to Control Systems 

In situations where Control Systems Data want to display processed data, this data can be forwarded 
by MultiTrend, using one of the available interfaces, e.g. CorrOcean Modbus Module.  This module 
has a signal-mapping program, RegSigMap, which makes data (here called signals) visible for 
systems outside MultiTrend via the Modbus Interface. 
 
As an example we have a MultiTrend configuration with an ER-probe connected via a SubSea 
instrument and a Modbus link (shown as RegSigMap in Figure 8787) to the MultiTrend PC. 
 

 
Figure 8787 ER-probe in Subsea / Modbus system 

Processed data for the ER-probe can be mapped and sent via the Modbus link as described in Figure 
8888. 
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Name of probe

Indicates direction of
data flow, relative to

MuliTrend

Name of signal to be
forwarded

Name of Modbus
Slave

Data Unit

Format of Modbus
register to hold data

Register Size

Modbus register
address

Data Display
 

Figure 8888 Typical mapping of output signals 

On each update of data in MultiTrend, the selected signals will be forwarded to the Control System 
(or whatever other system is connected to the Modbus link). 
 
See also 5.11.6 - Data Export and Import. 
 
 
 
 

5.9.7 Online Data Import from Control Systems 

In some cases the Control System is able to relay process parameters, such as flow data, pressure 
and temperature data, using one of the available interfaces, e.g. CorrOcean Modbus Module.   This 
module has a signal-mapping program, RegSigMap, which makes data (here called signals) visible 
for systems outside MultiTrend via the Modbus Interface. 
The method is an alternative to entering such process parameters manually in MultiTrend. 
 
As an example we have a MultiTrend configuration with a Sand Probe connected via a SubSea 
instrument and a Modbus link (shown as RegSigMap in Figure 8989) to the MultiTrend PC. 
 

 
Figure 8989 Sand probe in SubSea / Modbus system 

In sand rate calculations, flow and particle size probes are used for input. 
When for example flow data is relayed from the Control System, this data enters MultiTrend via the 
Modbus link and RegSigMap. 
An example of signal mapping for data import to MultiTrend is shown in Figure 9090. 
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Figure 9090 Mapping of import data 

5.9.8 Selecting byte orders 

Various Control Systems tend to have different byte orders for the Modbus data packets. 
In the Register Format column of RegSigMap, register formats can be chosen to conform with the 
byte order of the Control System, as shown in Figure 9191. 
 

 
Figure 9191 Selecting byte order 

The different concepts for swapping bytes and words are shown in Figure 9292. 
 

Byte

Word

A B C D E F G H

A BC DE FG H

E F G H A B C D

A BC D E FG H

Standard

Byte Swapped

Word Swapped

Byte/Word Swapped
 

Figure 9292 Byte and Word Swapping 
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5.10 Using MultiTrend with Weight Loss Coupons 

5.10.1 General 

The weight loss coupon is a probe, which is manually analysed to give information about corrosion 
and erosion in a system. The data for this probe type is now possible to store in MultiTrend.  

5.10.2 Install 

Because the weight loss coupon data is only entered manually, it is added and operated in General 
View. It is visible under the unconnected symbol in instrument view. 

5.10.2.1 Creating a MultiTrend Configuration 
To create a clean configuration file, select File->New on the pull down menu. Give the new file a 
suitable name e.g. "Weight Loss Coupon" so that it can be easily recognized. 

5.10.2.2 Creating a system tree 
To organize the probes visually the system item and pipe item are used. 
To add a system to the item, right click on the root symbol in General View and choose system in the 
context menu, Figure 9393. In the Create new system dialog enter a suitable name for the system. 
Add a pipe to the system and a Weigth loss coupon the same way you added the system to the root. 
To add the Weigth Loss Coupon to the pipe choose “probe” on the context menu and the dialog 
shown in Figure 9494 will appear. Enter the Tag name for the probe and choose Weight Loss Coupon 
in the type drop down list. 
 

 
Figure 9393 Add System Item 

 
Figure 9494 Add the Probe 

 
To finish the installation of the probe the different parameters in the following dialogs is optionally 
filled in. The finished configuration should look like Figure 9595. 

 
Figure 9595 Weight Coupon Configuration 
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5.10.2.3 Registering a measurement for the probe 
Select the weight loss probe; the details for the probe will appear at the right in the picture as shown 
in Figure 9696.Choose “Commands” in tab menu. Activate the “Initial Coupon Data >>” button. 
 
 

 
Figure 9696 Details Window 

In the Weight Loss Coupon Initial Data, dialog shown in Figure 9797 (Removal of coupon part of the 
dialog will not be shown) the data for the coupon on installation is registered, slect OK when 
finnished. To register the results after removal of coupon activate the “Removed Coupon Data >>” 
button. The dialog is now shown with the removal of coupon frame added to the dialog. Enter the 
data for the removed coupon. Select OK when finished. 
 

 
Figure 9797 Removed Coupon Data 
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5.10.2.4 Plot the data 

To plot the data choose “Calculations” in the details tab. To plot data press the  button. To view 

the data in a table format press the  button. See 5.12.1.1 for more information about plotting. 
 

 
Figure 9898 Plot Weight Loss Coupon Data 

5.11 Data Management 

5.11.1 Delete Probes 

In the General View or the Instrument View, select the probe you want to delete. 
 
Probes can be deleted/removed in two ways: 
 

1. Select the Edit ->Remove Probe 
2. Select Remove Probe on the probe Context menu 

 

 

 
Figure 9999 Delete Probe 

Any of these actions will bring up a warning that all measurements for the probe will be deleted.  
If you still want to remove the probe press the OK button, if not press the Cancel button 
 
WARNING 
If you delete a probe, all probe information and measurements will be deleted! 

5.11.2 Delete Configurations 

To delete a Configuration use your file manager to delete the files where the configuration data is 
stored. 
 
WARNING 
If you delete a configuration, all instrument and probe information in this configuration will be deleted. 
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5.11.2.1 Delete Instruments 
In Instrument View Window, select the instrument you want to remove. 
 
Instruments can be deleted/removed in two ways: 
 

1. Select Edit ->Remove Item 
2. Select Remove Item from the instrument Context menu 

 

 
 

Figure 100100 Delete Instrument 

Click the OK button if you still want to delete the probe. 
 
The probes which were connected to the instrument will loose its instrument connection and will be 
located under Unconnected probes in Instrument View. 

5.11.3 Backing up configurations 

All MultiTrend probe data is stored in the same database, where every probe has its own table. 
The database and configuration file (.mdb and .mcf files respectively) can be backed up using the  
File->Backup command. 
 

 
Figure 101101 Backing up configuration and database 

This command creates a copy of the active configuration along with its database file. 
The original files are left unchanged. 

5.11.4 Reducing database size 

If the database becomes very large, data compression can be performed to reduce the size of the 
database, and thus free disc space. 
This can be done in two ways. 

5.11.4.1 Replace database 
This is the simplest way to do this: 

• Stop MultiTrend 



CorrOcean ASA 
MULTITREND USER MANUAL 
Document No.: 4174-16959-I-MU-0003 

Rev:  04 
Page:  62 of  125 
Date:  03.10.04 

 
• Rename the database file e.g. by adding a number to it so that many numbered database 

files can be stored. E.G. From ExampleConfig.mdb to ExampleConfig 001.mdb, 
ExampleConfig 002.mdb etc. 

• Copy the configuration file and give it the same name. E.G. Copy ExampleConfig.mcf to 
ExampleConfig 001.mcf 

• Start MultiTrend. MultiTrend starts with an empty database file (The new file is automatically 
created). The old file should be archived for later use. 

 
The drawback of this method is that the recent historic data is unavailable for trending/plotting with 
new data.  

5.11.4.2 Data Compression 
To compress the database, use the following method: 

• Make a backup of the database described in 5.11.5. Use the current filename and add a 
number. E.g. ExampleConfig002 

• Compress the database as described in Figure 102102 and Figure 103103. Repeat for all 
probe types.  

 
The compression works by deleting measurements that are within the specified limit from the 
previous and following measurement. The size of the limit thus controls how coarse the history 
becomes. The higher the limit, the more measurements will be deleted and the history becomes 
coarser.  
Data compression can be performed on individual probes, or on all probes in a configuration. 
 

Select the
Commands tab

Seect Database
Compression

Select one sand
probe

 
Figure 102102 Compressing the database (1) 

 



CorrOcean ASA 
MULTITREND USER MANUAL 
Document No.: 4174-16959-I-MU-0003 

Rev:  04 
Page:  63 of  125 
Date:  03.10.04 

 
Keep the most recent

history to allow trending
with new data.

Not recommended
Apply same
compression to all
probes of the same
type

After setting
parameters,
compress all probes  

Figure 103103 Compress database (2) 

 
NOTE 
The Data Compression operation cannot be undone. 
Data deleted during compression cannot be recovered. 
 
Enabling Automatic compression at midnight makes MultiTrend automatically perform data 
compression with the predefined settings. 
 
NOTE 
All data retrieval is halted during compression. 
For large databases, compression can take quite a while – therefore automatic compression is not 
recommended if data acquisition is crucial. 

5.11.5 Backing up files 

• Enter Service Mode 
• Select File->Backup from the pull down menu 
• Enter a suitable name and location for the backed up files 

5.11.6 Data Export and Import 

MultiTrend ver. 2.29 or later contains a feature for extracting data to ASCII type file, either within a 
specified interval or continuously as data is retrieved. For instance, all data since last export can be 
extracted offshore, sent by e-mail to a PC onshore running MultiTrend.  Here the data can be 
appended to the existing database.  Alternatively, MultiTrend can export the file directly to a 
networked location, so that users connected to the network can import the file on their local 
computers. 
 
The user can select what data to export, and optionally set MultiTrend to import automatically at 
start-up. 

5.11.6.1 Data Export 
To export probe data from MultiTrend select File->Export Data. 
Data export can be done either manually or automatically in Online Mode. 
Manual export gives two choices – either export data since last export or export a selected time 
interval.  Automatic export in Online Mode exports data each time new data is retrieved by 
MultiTrend. 
The user can select which probes to export, and what unit to use for each signal. 
The signals for each probe type are predefined. 
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The settings of the Export definition dialog are saved when pressing either Save and export or Save 
and close.  When exporting manually the user is asked to append or overwrite if the specified export 
file already exists. 
 
Figure 104104 shows the Export definition dialog. 
 

View either General
or Instrument View Specify file for storage

Specify start time for
online export

Specify interval for
manual export

Specify unit for selected
signal

Select signals for export

Set to ON for automatic
export in Online mode

Save settings and export Save settings Cancel without save  
Figure 104104 Export definition dialog 

The exported ASCII file contains a standardized file header as well as the data. 
 
 
 

5.11.6.2 Data Import 
 
For manual import of exported probe data, select File->Import Data.  The dialog that appears gives 
five possible import file types: 
 

 
 

1. MultiTrend Export Files (*.txt) – ASCII file exported using MultiTrend export function. 
2. SandRater Temporary File (*.tmp) – ASCII file containing SandRater temp data file. 
3. SandRater/CorrList Files (*.dat) – Datafiles used in Sandrater/Corrlist programs 
4. MultiCom Files (*.txt) – Datafile used in Multicom program 

 
If, for instance, a MultiTrend export file is to be imported, selection of such a file results in a dialog as 
shown in Figure 105105.  Select signal(s) that shall be imported and press Import. 
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Figure 105105 Signal import selection 

For automatic import at start-up, select Edit->Options, as well as the “Automatic File Import” tab, as 
shown in Figure 106106. 
Tick the Import the following file after start-up and optionally Delete the file after import, and specify 
the file to be imported.  The delete option should not be used if more than one user need access to 
the export file. 
Press OK and save the MultiTrend configuration. 
If the import file contains data already stored in the database, this data is ignored. 
 
 

 

 
Figure 106106 Automatic Import Setup 

 

5.11.6.3 SandRater Import 
The SandRater import supports import of historical data from SAnn.TMP and SAnn.DAT files.   
Tag number and probe parameters stored in the PROBE.DBF or HIST.DBF files are not imported 
and must be entered manually.  
Temperature compensation values are not imported and must be entered manually or calculated by 
MultiTrend. The temperature compensation values from SandRater (and the probe certificates) can 
be used, but must be slightly modified. 
The SandRater parameter A (coefficient) must be divided by 1000000 (106) and input as parameter B 
in MultiTrend. 
 
 



5.12 Data Analysis 

This section describes the data analysis possibilities for the various probes in MultiTrend. 
The most widely used probes are emphasized. 

5.12.1.1 Plotting data 
MultiTrend has a powerful built-in plotting/graphing tool. To use this function choose plot from the 

context menu, alternatively select the  button on the toolbar or in the Detail Window to open the 
plot data selection window shown in Figure 107107.  After selecting the data to plot, click the OK 
button.  The plot window comes up with a default axis scale setting. Use the zoom, pan and ruler 
tools to manipulate the data for best display. 
 

Select the data you
want to plot here and

add it to one of the
axis lists by using

one of the Add
buttons

Set desired lable

Select the range of
data you want to plot

here

Select the unit you
want to plot in here

 
Figure 107107 The plot data selection window 

 
 
 
 
 
 
 

5.12.2 Sand probe analysis 

The sand probe  analysis choices can be viewed by selecting a probe in any of the three views 
(General, Instrument, Status). 

5.12.2.1 Analysing sand data 
The best way to analyse the sand data is to plot metal loss. A flat curve indicates no erosion and thus 
no sand. Increasing trends indicates erosion, and thus sand production. An apparent drop in metal 
loss can occur during large changes in temperature on the probe such as shutdowns. When the 
temperature stabilises, the metal loss will return to the original level. 
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Figure 108108 Available Sand Probe analysis 

The analysis choices are: 

5.12.2.2 Metal Loss 
Calculates Metal Loss for each of the probe’s elements based on the element resistance value. 
Select the plot button  to create a plot of the probe’s Metal Loss. 
From the F>> button, you can access the analysis settings.  This gives you the opportunity to 
calculate Metal Loss offsets and apply filters. 
Figure 109109 shows the Metal Loss Calculation Parameters dialog. 
 

 
Figure 109109 Metal Loss Calculation Parameters 

The various calculation parameters and settings are described on next page. 
 
 
 
 

5.12.2.3 Offsets 
There are two methods’ for adding offset to the signal.  
 
Initial Metalloss adds an offset to the first sample in the dataset. All other samples will be displaced 
relative to the first. The value of the offset is entered in the detail window -> parameters for the probe 
Figure 110110. Figure 112112 shows an initial metalloss of 2µm. This option is used for making the 
data continuous after a probe replacement. 
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Figure 110110 Detail window 

Calculate offset adds an offset for all elements in the last current sample in the dataset. When 
calculated the offset will move the data point to the zero line or to initial metalloss value if it’s 
applied. All other data will be displaced relative to this point. This option should always be used when 
a new probe is installed, however first a reading should be taken on the new probe, then the probe 
offset should be calculated. 

 

Figure 111111 Signal with no offset 
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Figure 112112 Signal with initial offset 2µm 

 

 

 

Figure 113113 Signal with calculated offset -4µm 
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5.12.2.4 Temperature Compensation 
 
The sand probes may show some dependency to the ambient temperature.  This may be visible if 
trending is performed when large temperature changes occur, such as during a start-up or shutdown 
of a well.  Temperature compensation may therefore be performed to correct for this dependency.  
The probe certificate supplied with each sand probe contains the necessary values to input to the 
temperature correction function. To enable temperature correction, input the values given on the 
probe certificate and check the Do Temperature Correction box in the Metal Loss Calculations 
Window.  If the probe certificate only specifies one “A” and “B” value, use the same values for all 
elements. 
 

Set desired interval

Use # parameters
(see probe certificate)

Enter Parameters from
probe certificate

 
Figure 114114 Temperature Compensation Parameters 

 
Alternatively, the values can be calculated by MultiTrend.  To make MultiTrend calculate the values, 
input a suitable time range where there has been a significant temperature change  (a start-up or 
shut-down) and press the Calculate Parameters button.  MultiTrend will now automatically input the 
best parameters.  You may optionally generate 2 to 4 parameters.  The A parameter is the calculated 
average reference reading in ohm.  The B, C and D are compensation parameters.  The Correlation 
Factor shows the correlation between changes in the reference element readings and the measure 
element readings.  A figure close to 1.0 indicates a very good correlation and therefore possibly a 
good temperature compensation.  A correlation less than 0.5 indicates that there is not much 
correlation between changes in the two data sets. 
 
When calculating compensation parameters, always check the given results by doing trending.  A 
trend plot with and without the temperature compensation enabled will show the effect of the given 
parameters. 
 
WARNING 
This operation should only be performed by experienced personnel! 
 
 
 
 
 
 
 
 
 
 
 
 



CorrOcean ASA 
MULTITREND USER MANUAL 
Document No.: 4174-16959-I-MU-0003 

Rev:  04 
Page:  71 of  125 
Date:  03.10.04 

 
5.12.2.5 Filter Parameters 
Filters are selected by checking the relevant boxes shown in Figure 115115. 
 

Check to select
filter

 
Figure 115115 Filter settings 

Average Filter 
The average filter settings tab allows the user to set the interval over which the readings will be 
averaged. 
 
Spike filter 
Delta limit should be set so that any sample out with that limit is rejected.  
Spike width determines how many samples must be greater than the delta limit before the data is 
accepted as valid.  
Filter width determines how many samples back MultiTrend looks when calculating the average. 
 
Spikes may appear as single point spikes (Spike 1) or multi point spikes (Spikes 2 & 3).  The spike 
filter settings tell MultiTrend how to react to spikes.  Shifts in amplitude (Y-axis value) may just as 
well be ramps that we want to see in the resulting plot. 
                                   Spike 1   Spike2              Spike3 
 
 

 
Figure 116116 Unfiltered spikes 
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In this example we consider Spike 1 and 2 as “real” spikes Figure 116116.  These are to be filtered 
while keeping Spike 3. 
The filter settings will be as follows: 
 

 
Figure 117117 Spike filter settings 

Delta Limit is set to 3 µm, because we want to detect all jumps in amplitude that exceed 3 µm. 
Spike Widths in samples is set to 2, because we want to remove all jumps in amplitude (over 3 µm) 
that consists of one data point (measurement). 
This parameter cannot be set to a lower value than 2. 
With Filter Width in samples set to 10, we replace the removed data point(s) with the average of the 
8 previous measurements. Samples used to calculate average are decided from Average Width 
minus Spike Width. 
The resulting plot looks like Figure 118118: 
 

 
Figure 118118 Spike widths 2 Green signal is filtered 

 
Observe in Figure 118118 that the spikes that consist of two and three samples also get filtered but 
only the first measurement of the spike is removed. 
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If the spike width is increased to 3 points the result will look like Figure 119119 
  

 
Figure 119119 Spike widths 3 Green signal is filtered 

To get the right filter settings, you must first view the data you want to plot.  If the plotted data 
contains one or several spikes, you must determine the appropriate amplitude to set as threshold 
(Delta Limit) as well as the maximum number of data points a spike can contain (Spike width in 
samples) for a good result for the filter. Figure 120120 shows the dataset with spike width 4.  
 
 

 
Figure 120120 Spike width 4 Green signal is filtered 

 
The Filter Parameters are used to set averaging parameters.  When a filter has been turned on, the 
displayed values in the Probe Status View, the Calculations View and the trend plots are always 
based on the current settings of the parameters.  
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It is possible to display trend plots with different filter parameter settings by changing the filter 
settings and then select the Add Curve function in the Graph Window. 
 
NOTE 
Filter settings changed in the plot definition window does not affect the filter setting defined in the 
Probe Calculations view. 

5.12.2.6 Erosion Rate 
The Erosion Rate is calculated based on the calculated metal loss. Any Average Filter defined in the 
Metal Loss filter window will not affect the erosion rate calculations. However, any spike settings 
applied will affect the calculations. This dialog can be accessed clicking the F>> button for Erosion 
Rate in details window (Figure 121121). 
  

 
Figure 121121 Available Sand Probe analysis 

 

 
Figure 122122 Rate Calculation 

The erosion rate is calculated based on two or more metal loss readings defined by the integration 
period given in the Rate Calculation dialogue.   
 
Normally an integration of 6-10 measurements is sufficient.  This should give a quick response, as 
well as reduce the rate noise.  If the response is not quick enough, the integration time can be 
lowered.  Lowering the integration period will give quicker response, but may also make the curve 
noisier (very few measurements in integration combined with noisy signal/measurements). 
 
For the sand probe, the erosion rate will be input for the sand rate calculations. 

5.12.2.7 Sand Rate 
Sand Rate is calculated based on input of production data parameters flow and particle size. 
The Sand Rate parameters allow the user to select which flow and particle size probes are to be used 
for the sand calculation. The probes can be selected from the pull down menu. 
Probe position in the spool is also selected here, toggling from front to rear by clicking the relevant 
check box. This dialog can be accessed clicking the F>> button for Sand Rate in details window 
(Figure 121121). 
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Figure 123123 Sand Rate Calculation Parameters 

Changing the probe position affects the sand production constants. These values are default values 
set by MultiTrend.  Different constants can be used by unchecking the ‘defaults’ check box, and then 
entering new values in the fields.  
 
WARNING 
Only experienced personnel should alter the sand production constants values! 

5.12.2.8 Sand Content 
The approximate amount of sand, related to oil, water and/or gas, can be calculated and displayed. 
This dialog can be accessed clicking the F>> button for Sand Content in the details window (Figure 
121121). Check the desired medium in the dialog shown in Figure 124124. 
 

 
Figure 124124 Sand Content Calculation Parameters 

5.12.3 ER-probe Analysis 

ER-probe analysis includes Metal Loss and Corrosion Rate. 
Settings and use are the same as described for Sand Probe in sections 5.12.2.2 and 5.12.2.6. 

5.12.4 Analogue Probe 

The Analogue probe functions much like a voltmeter, and measures voltages. 
The data can represent different dimensions and can be manipulated mathematically using the 
Polynomial Calculations, as shown in Figure 125125. This dialog can be accessed clicking the F>> 
button in details window.  
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Figure 125125 Polynomial Calculations 

The formula VFxExDxCxB
x
AxF 432)( +++++=  is applied to the measured data (x), and by 

entering values in the Constants fields, a mathematical calculation can be made. 
If no calculation is wanted (e.g. only raw values), constant C is set to 1 leaving the other constants 
zero. 
In addition, filters can be applied to the data.  Filter settings are described in section 5.12.2.2. 

5.12.5 Temp/Pressure Probe 

The Temp/Pressure probe has a function to enable correction for dependency to the ambient 
temperature. 
The function and parameters are shown in Figure 126126. This dialog can be accessed clicking the 
F>> button in details window. 
 

 
Figure 126126 Temperature Calculation Calibrations 

WARNING 
The Temperature Calculation Calibration should only be used by experienced personnel. 

5.12.6 Remaining probe types 

The remaining probe types share the Temperature Compensation and filtering features described in 
5.12.2.2. 
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6 FSM FUNCTIONALITY IN MULTITREND 
 
This chapter explains how to use FSM instrumentation in MultiTrend. FSM Functionality is available 
in MultiTrend from version 3.01. 
 

7 WHAT IS FSM? 
 

7.1 FSM - Field Signature Method 

 
The FSM method is based on sensing changes in the electric field pattern set up by an electric 
current fed through the object to be monitored. By proper interpretation of these changes in potential 
differences over time, conclusions can be drawn, i.e. about corrosion rate or crack growth.  
 

7.2 Measurement Principle 

The FSM measurement principle is a non-intrusive monitoring technique designed to detect small 
changes in wall thickness.  The technique involves passing a controlled excitation current through the 
structure to establish a unique electric field signature.  Any subsequent changes that appear in the 
electric field, as a result of corrosion / erosion, will be detected as changes in the electric potential 
across sensor pins attached to the outside of the structure. 
 

 
Figure 127127: Pipe with current excitation. Current distribution and voltage potentials 
show a regular pattern. 
 
 

 
Figure 128128: Pipe with current excitation and a local defect. Current distribution and 
voltage potentials will change around the defect.  
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7.3 Types of corrosion 

7.3.1 General Corrosion: 

By general corrosion we mean uniformly distributed metal loss inside the structure, causing overall 
increased resistance. The current distribution will be uniform, and the wall thickness reduction will be 
linearly related to the increase in resistance and measured pin pair voltages. The increase in the 
measured pin pair voltages can be directly converted to the general metal loss. 
 

7.3.2 Weld Root Corrosion / Groove Corrosion: 

Weld root corrosion may occur at welded sections of a metal structure. On a pipe, the weld root 
corrosion takes the shape of a groove, following the weld along the circumference of the pipe. The 
width of the groove is often narrow compared to the FSM pin pair distance. Since the metal loss is 
not uniform, but only attacks a subsection of the metal structure, the wall thickness measurements 
will be strongly underestimated. The FSM measurements must be compensated by an empirical 
model for weld root corrosion, where the actual depth of the groove is calculated by a special 
algorithm.  

7.3.3 Pitting: 

Pitting introduces an even more complex situation than weld corrosion. Where a pit occurs, the 
increased resistance will cause the current to flow around the pit. In unprocessed data, the data 
pattern in an FSM matrix will show the highest value on top of the pit, increased values to the sides 
of the pit, and negative values in front of - and after  - the pit (referring to the FSM current direction). 
The pit will look wider than its actual size, and the depth value is strongly underestimated.  
 
If pitting analysis is not activated, the wall thickness measurements will be strongly underestimated.  
Pit analysis is not available for common users pr May 2003. NOTE! At present, manual analysis by 
CorrOcean is needed. 
 

7.3.4 Bend Erosion 

Whenever sand is mixed into a fluid flow, the bends and curves of a pipe system will suffer from 
erosion wear due to the sand particles hitting the pipe wall. The geometry of erosion wear can vary, 
depending on the process and the geometry and material of the pipe. Erosion damages are non-
uniform with respect to pipe geometry. The most severe metal loss is found in the outer curve of the 
bend. 
 
Due to the non-uniform shape of erosion damages, the erosion depth will be underestimated without 
special processing. Thus, a special application for compensation of metal loss depth in erosion 
damages has been developed.  
 

7.4 General sensitivity (Dependent on logging interval) 

• Even corrosion: Typically +/- 0,03% of WT when taking one reading/hour (online powered). 
• Even corrosion: Typically +/- 0,1% of WT when taking one reading/day (battery powered). 
• Even corrosion: Typically +/- 0,5% of WT for FSM-IT (off-line). 
• Pitting corrosion: Typically +/- 0,5% of WT (online powered). 
• Weld root corrosion: Typically +/- 0,2% of WT (online powered). 
• Bend erosion: Typically +/- 0,2% of WT (online powered). 
 
WT: Wall Thickness 
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7.5 Absolute accuracy 

• Even corrosion: Typically +/-0,03% of WT (online powered). 
• Even corrosion: Typically  +/-0,1% of WT (battery powered) 
• Pitting corrosion: Typically +/-20% of pith depth (for shallow pits and battery powered). 
• Weld root corr.: Typically +/-10% of groove depth (for shallow groove and battery powered). 
• Bend erosion: Typically +/-20% of erosion depth. 
 
WT: Wall Thickness  

 

8 FSM INSTRUMENT CONTROL IN MULTITREND 
 

8.1 Using MultiTrend with FSM G4 Station 

This section describes the setup of an FSM G4 station. 

8.1.1 Creating a MultiTrend configuration file 

To create a clean configuration file, select File->New on the pull down menu. Give the new file a 
suitable name e.g. "FSM Installation" so that it can be easily recognized. 

8.1.2 Adding a Serial Com Interface 

For connection via the PCs COM port, MultiTrend must be configured with a serial interface.  
Select Edit->New->Interface from the pull down menu as shown Figure 129129(or New->Interface 
from the context menu).  

 

 

 
Figure 129129 Creating an interface 

 
This brings up the interface selection window, shown in Figure 130130 interface selection select 
serial and press the Next> button. 
 



CorrOcean ASA 
MULTITREND USER MANUAL 
Document No.: 4174-16959-I-MU-0003 

Rev:  04 
Page:  80 of  125 
Date:  03.10.04 

 

Select the type of
interface you want

Select Next to
proceed

 
Figure 130130 Interface selection window 

 

If your serial port is
not listed, you can

type it in here

Select the Finish
button to complete
the creation of the
interface

 
Figure 131131 Port Configuration Window 

Now your Instrument View contains an icon representing the new serial interface (Figure 132132). 
Select the icon and choose the setup tab in the detail window. Select the baud-rate according to 
sensor documentation. In most cases the other parameters can be left with their default values. 
 

Select the new
interface to display

its detail window

Select The setup tab
to display the serial
port settings

Select baudrate
according to sensor
documentation

 
Figure 132132 Setting the serial port properties 
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8.1.3 Adding the G4 Instrument 

To add a new instrument, select Edit->New->Instrument as shown in Figure 133133.The dialog for 
new instrument as shown in Figure 134134.Here you choose instrument type FSMStation G4 in the 
type drop down menu and enter a name for the instrument in the Tag field. There is also possible to 
use the G4 station on a field bus master system. How to set up the field bus master is described in 
5.6.2.3.  
 

 

 
Figure 133133 Adding a new instrument 
menu 

 

 
Figure 134134 Instrument dialog 

 
The configuration tree in the instrument view will look like Figure 135135 after finishing the previous 
steps. If a field bus master is used, the bus address must be applied in the address tab in the details 
dialog, 8.2.3 for the instrument. 
 

 
Figure 135135 Instrument added to configuration 
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8.1.4 Adding a matrix  

Right click on the instrument and choose New->Matrix->FSM Pin Matrix. 
 

 
Figure 136136 New FSM Matrix dialog 

 
Figure 137137 New FSM Matrix parameters 
dialog 

 
The matrix installation wizard will now appear, Figure 136136, a tag name for the matrix is required. 
Press the Next button when finished. In the parameters dialog leave the matrix temperature sensors 
to the default, if not otherwise stated in the documentation; choose the local power grid frequency to 
match the installation site power supply. Press the FSM Pin Matrix Editor button. The FSM Matrix 
Editor is started and will contain an empty configuration; the matrix layout is set up manually from the 
documentation or by importing a template. In this example the configuration is loaded from the 
template 64Pins_G4 found under FSM Matrix Templates on the MultiTrend install CD. The 
configuration for G4 with 64 pins is shown in Figure 138138. To import the template open file menu 
->Open Template and browse the CD for the 64Pins_G4 template file, save the loaded setup. Close 
the matrix editor.  
 

 
Figure 138138 Configuration 64 pins G4  
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The items in the last parameters dialog, Figure 139139 ,in the wizard is optional. Press Finish when 
done. 
 
 

 
Figure 139139 New FSM Matrix parameters 

 
 

 
The items needed for the configuration is now complete, the setup shall now look like Figure 140140 
 

 
Figure 140140 Complete instrument setup 

Details 
Window 

Pin 
Matrix  

FSM 
Station 
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8.1.5 Configuring the Installation 

 
Choose the FSM instrument in the tree view and the details window will appear with the following tab 
strip with the items shown in Figure 141141 
 

 
Figure 141141 Tab strip 

Information about the different dialogs is found in 8.2G4 Instrument detail dialogs.  
To verify that the instrument is connected and works, choose Status Details dialog and activate the 
“Get From Instrument” button. In the Log window information about progress will be displayed, if 
communication is OK, information will appear in the text fields in the dialog. 

In this example we will verify the set-up loaded in the template. 
Choose the Matrix in the instrument dialog. Information about the different dialogs for the matrix is 
found in 8.4FSM Station Matrix detail dialogs. After opening the Pin Matrix Editor verify that the 
setup consist of 64 pins that are distributed sequentially over 8 AD converters with the last pair on all 
AD converters to be a long pair consisting of the 1st pin in the first pair and the last pin in the 7th pair. 
Select the Current Feeds dialog and verify that the following parameters with corresponding values 
are as listed in Table 11. 
 
Feed Number 1 1 
Excitation Voltage 18 V 
Pulse length 1700 ms 
Stabilisation Time 1000 ms 
Average Measurements  1 
Table 11 Excitation Current Parameters 

Close the Pin Matrix Editor.  
 
Open the Advanced command’s dialog found in the commands dialog for the instrument. 
Activate the Send Pin Configuration button. (MultiTrend must be in advanced mode to perform this 
operation). Exit the dialog after the transfer is done. 

8.1.5.1 Configuration of automatic logging 
There are two possibilities for enabling logging on the system;  
Alternative 1 is to set up the instrument to perform the measurements at a preset interval. 
Alternative 2 is to let MultiTrend start the measurement when automatically retrieving the 
measurements in online mode. 
 
The preferred choice is alternative 1 because if the MultiTrend software loses contact with the 
instrument for a period of time, the instrument keeps on logging, which it won’t when, using 
alternative 2.   
 
To activate instrument initiated measure activate the Change button found in the commands dialog in 
the details windows for the instrument, Figure 143143, select the interval in the pop up dialog and 
turn the switch button to ON. 
Now MultiTrend will configure the instrument to perform measurements to the set interval. 
 

8.1.5.2 Configuration of automatic retrieval 
Enter the wanted interval for automatic retrieve in the commands dialog for the instrument. Unhook 
the “Measure before Retrieve” checkbox. Turn the switch button to ON. 
IMPORTANT: MultiTrend must be in Online mode to automatically retrieve data. 
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8.1.5.3 Manually Started measurement  
To manually start a measurement, open the commands dialog in the details window for the 
instrument and activate the Advanced Commands button, in the dialog opened a manual 
measurement can be started. The operation is available in service mode and advanced service 
mode. 
 

8.1.5.4 Manual retrieval of measurements 
To manually retrieve a measurement open the commands dialog in the details window for the 
instrument, the retrieve button is found in the automatic retrieve frame. If the measure before 
retrieve check button is checked the instrument will perform a measurement before the retrieval is 
done. 
 
 

8.2 G4 Instrument detail dialogs 

8.2.1 Description dialog 

The description dialog is used to store general information about the instrument (user input). Editable 
in service and advanced service mode. 
 

8.2.2 Information dialog 

In the information dialog Part/Ser number, Order number, Manufacturer and installation date is found 
or can be entered if not already done. Editable in service and advanced service mode 

8.2.3 Address dialog 

In the address dialog Figure 142142 the logger and the Analog/Digital converter addresses found. 
The addresses are only editable in advanced service mode.   
 
 

 
Figure 142142 Instrument address dialog 

 
Figure 143143 Instrument commands dialog 

 



CorrOcean ASA 
MULTITREND USER MANUAL 
Document No.: 4174-16959-I-MU-0003 

Rev:  04 
Page:  86 of  125 
Date:  03.10.04 

 

8.2.4 Commands dialog 

In the commands dialog (Figure 143143) settings for configuring the instrument are found 
 
Automatic Measure: The instrument is configured to automatically perform measurements, 
available in service and advanced service mode. 
 
Automatic retrieve: MultiTrend is configured to automatically retrieve data in online mode, available 
in service and advanced service mode. 
 
Measure before retrieve: MultiTrend starts a measurement before automatically retrieving the data, 
available in service and advanced service mode. 
 
Apply to all loggers: Configure all connected loggers connected to the physical interface with the 
current settings (Typical usage is multiple loggers on a field bus master system), available in service 
and advanced service mode. 

8.2.5 Advanced commands 

Advanced commands button opens the Interactive Logger Commands dialog Figure 144144, which is 
available in service and advanced service mode. In service mode the only commands available are: 
Start Measurement, Unmark Measurements and Logger shutdown command. 
 

 
Figure 144144 Interactive logger commands 

In Advanced mode all parameters and commands are available, the different parameters and 
commands are: 

• Logger Name: This parameter is used to set a describing name of the station. This name 
would normally be set to the name of the station's location. 

• Communication frame size: This value defines the maximum frame size the station will use 
when communicating. This value should be 1024 bytes (the maximum value) unless the 
communication system requires smaller frames to be used. Also, on noisy communication 
links, this value could be decreased to possibly reduce the number of retries needed to 
transmit data from the station, as the probabilities of smaller frames to be corrupted are less 
than for larger frames. The minimum frame size possible is 10 bytes.  
NB! 1024 bytes frame size must be used if the communication with the logger is done 
through a CorrOcean Field Bus Master, 

• Character receivable timeout: This timeout value defines how many milliseconds the 
station should wait for the next transmitted character when one or more characters have 
been received on any communication port. Read only for normal G4 station. 

• Battery limit: Set battery voltage to cause the instrument to enter emergency mode if the 
supply battery voltage becomes lower than the limit set. 
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• Wakeup acknowledge: This setting enables or disables the wakeup acknowledge response 

from the FSM station when it is awaken by communication. 
• Battery Burning: This parameter specifies if the station should perform battery burning when 

awaken to make sure it gets enough power from the batteries. When selected, battery 
burning will be performed (Normally not used). 

• A/D error/timeout: indicates if there is a problem with the A/D-converters in the FSM station. 
• Station ID/address/location: These parameters hold information about the stations ID and 

location. The Station ID parameter defines a unique number that can be used to identify the 
station. The Address parameter is used when the station is connected to some sort of a 
communication bus (like a field bus) and identifies the stations address on the bus. The 
Location parameter can be used to specify which number this station has on a specific 
location. 

• Broadcast: If the node address of the FSM station is not known a broadcast could be used to 
communicate with it. No other devices can be connected to the bus when broadcast is being 
used. 

• Start measurement: This command will make the FSM station perform a measuring 
sequence. The measured data will be stored in the stations internal memory, and can be 
subsequently retrieved by using the data retrieval commands. The station will be busy during 
the measurement (this could take several minutes), so no response should be expected to 
any commands sent to the station in this period. 

• Delete measurements: This command will make the FSM station delete any internal 
measurement buffers that have been successfully transferred to MultiTrend.  

• Unmark Measurements: This command will make the FSM station remove a tag (which 
indicates successful transfer of a measurement buffer) from all its internal measurement 
buffers that have not been deleted. This command could be used to have the FSM station 
transmit all its internal measurement buffers upon the next data retrieval, even if they have 
been successfully transmitted earlier. 

• Logger Reset: This command will make the FSM station system reset. Any stored 
measurements will be deleted, and the station and measurement parameters will be reset to 
default values. If you get a NVRAM fault, you have to reset the system. 

• Logger Shutdown: This command will make the FSM station go to sleep. The FSM station 
will go to sleep automatically after some time of communication inactivity (depending on the 
communication system being used). 

• Leave Emergency mode: This command will reset the FSM stations internal error flags. 
This is the only way to make the FSM station leave emergency mode. The FSM station will 
not respond to any other commands than this command when it is in emergency mode. 

• Get Pin Configuration: Retrieves the pin configuration from the station and opens the Pin 
Matrix Editor to display the configuration.  

• Send Pin Configuration: Send the Pin Configuration from MultiTrend to the station.  

8.2.6 Communication options 

Communication options button opens the advanced Logger setup dialog Figure 145145, which is 
available in service and advanced service mode. In service mode all parameters are read-only:  
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Figure 145145 Advanced logger setup 

In advanced mode these parameters are available for editing: 
 

• Delay between commands: Time interval in milliseconds. Default value is 0. 
• Number of command retries: Determines how many times MultiTrend attempts each 

communication command before flagging an error. Default value is 10. 
• Delay before command retries: Time interval in milliseconds. Default value is 3500. 
• Retrieve failures before logger reset: MultiTrend will attempt to restart the logger if 

communications fail on successive attempts. The default value is 20. 
• Clear Logger Memory After Retrieval: Delete the measurements permanently in the logger, 

unmark command is not applicable if this option is checked. 
• Stop Retrieval After Failed Reset: If logger doesn’t respond after automatic logger reset 

MultiTrend deactivates the automatic retrieve function. 

8.2.7 Status Details Dialog 

This dialog displays general information about the logger. Information must be retrieved with Get 
From Instrument command. 
 

 
Figure 146146 Instrument status details 

8.3 FSM G4 Sub Probes 

The FSM G4 has one sub probe that contains housekeeping data. 
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Housekeeping probe:  
 

 
Figure 147147 Housekeeping probe 

8.4 FSM Station Matrix detail dialogs 

8.4.1 Calculations dialog 

In the calculations dialog Figure 148148 information about the measurements is found. 
• Raw Value: Shows the raw value for the pair chosen. To alter pair to be displayed press the 

 button to open the formula dialog. Here are all the available pairs for the matrix is 
shown. Only one pair at a time can be selected for display.  

• FC Value: Shows the calculated FC value for one pair. To alter pair open the formula dialog. 
In the dialog the available pairs for the matrix is shown. Only one pair at a time can be 
selected for display.  

• Metalloss: Display Calculated general metal loss based on all pairs. Available options for 
calculation are found in the formula dialog. Options are: Mean, Median, Maximum, Minimum.  

• Corrosion rate: Displays the rate based on the Metal loss calculation. Interval for setting the 
integration interval is found in the formula dialog.  

 
 
For all signals in the calculations dialog the following functionality are available: 
 

•  Displays the probe value in status view when checked. 

•  Displays the settings for Monitoring\Alarm. 

•  Displays the data in a table format. 

•  Displays the data in an XY Plot. 
 

 
Figure 148148 Matrix Calculations dialog 
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8.4.2 Description dialog 

The description dialog is used to store general information about the instrument (user input). Editable 
in service and advanced service mode. 
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8.4.3 Parameters dialog 

The parameters dialog Figure 149149 contains information about the matrix.  
• Matrix Temperature Sensors: Number of temperature sensors for the matrix, hardware 

determined. 
• Local Power Grid Frequency: Choose the frequency of the mains at the installation site. 

 
Information about number of measurement pins, pairs and current feeds for the matrix is found in the 
frame with the label Pin configuration. The Pin Matrix editor can be started from this dialog. 
 

 
Figure 149149 Matrix Parameters dialog 

8.4.4 Information dialog 

In the information dialog Part/Ser number, Order number, Manufacturer and installation date is found 
or can be entered if not already done in instrument installation dialog. Editable in service and 
advanced service mode 
 

8.4.5 Commands dialog  

The commands dialog for the matrix consist of a collection of buttons which start the following 
features: 

• Manual Measurement: Used to enter a manual measurement in the database for test 
purposes 

• Select signature: Select or create a signature that is used for calculating FSM results. In the 
dialog, the time interval used to calculate the signature must be entered. 

• FSM Pin Matrix Editor: Start the Pin Matrix Editor to configure the measurement set-up for 
the matrix. 

• Edit Raw Data: Edit the existing raw data in the database. 
• Data Compression: Starts the dialog for compression on the database.  

G4 Matrix Sub Probes 
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8.4.6  Matrix Sub Probes 

The matrix for the G4 station has two sub probes  
• Housekeeping probe  

 

 
Figure 150150 Housekeeping for the matrix 

• Temperatures probe 
 

 
Figure 151151 Temperatures for the matrix 

 

8.5 Using MultiTrend with the FSM IT instrument 

This section describes how to configure and use an FSM IT instrument with MultiTrend 

8.5.1 Creating a MultiTrend configuration file 

To create a clean configuration file, select File->New on the pull down menu. Give the new file a 
suitable name e.g. "FSM IT Installation" so that it can be easily recognized. 

8.5.2 Adding a Serial Com Interface 

For connection via the PCs COM port, MultiTrend must be configured with a serial interface.  
Select Edit->New->Interface from the pull down menu as shown Figure 152152(or New->Interface 
from the context menu).  

 

 

 
Figure 152152 Creating an interface 

 
This brings up the interface selection window, shown in Figure 153153 Select Serial and press the 
Next> button. 
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Select the type of
interface you want

Select Next to
proceed

 
Figure 153153 Interface selection window 

 

If your serial port is
not listed, you can

type it in here

Select the Finish
button to complete
the creation of the
interface

 
Figure 154154 Port Configuration Window 

Now your Instrument View contains an icon representing the new serial interface Figure 155155. 
Select the icon and chose the setup tab in the detail window. Select baud-rate 38400. 
 

Select the new
interface to display

its detail window

Select The setup tab
to display the serial
port settings

Select baudrate
according to sensor
documentation

 
Figure 155155 Setting the serial port properties 

8.5.3 Adding the FSM_IT Instrument 

To add a new instrument, select Edit->New->Instrument as shown in Figure 156156.The dialog for 
new instrument will appear as shown in Figure 157157.Here you choose instrument type “FSM IT 
Instrument” in the type drop down menu and enter a name for the instrument in the Tag field.  
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Figure 156156 Adding new instrument 
menu 

 

 
Figure 157157 Instrument dialog 

 
The configuration tree in instrument view should look like Figure 158158 after finishing the previous 
steps. 
 

 
Figure 158158 Instrument added to the configuration 

8.5.4 Adding a matrix  

Right click on the instrument and choose New->Matrix->FSM Pin Matrix. 
 

 
Figure 159159 New FSM Matrix dialog 

 
Figure 160160 New FSM Matrix parameters 
dialog 
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The matrix installation wizard will now appear, Figure 159159, a tag name for the matrix is required. 
Press the Next button when finished. In the parameters dialog leave the matrix temperature sensors 
to the default if not otherwise is stated in the documentation; choose the local power grid frequency 
to match the installation site power supply. Press the FSM Pin Matrix Editor to set up the matrix 
configuration. The FSM Matrix Editor is started and will contain an empty configuration. The matrix 
layout is set up manually from the documentation or by importing a template. In this example the 
configuration is made from scratch. For more information about the FSM IT instrument see the FSM 
IT instrument User Manual.  
 

8.5.5 Configuring the matrix 

To configure the matrix setup, MultiTrend must be set in advanced service mode. 
The matrix configuration setup consist of two list boxes, one showing the pins and the other one 
showing the sub matrixes that represent the hardware mapping to each SMI. (One SMI is a sub 
matrix). Add pins from the pin list box by clicking on the SMI the pins should be assigned to and then 
click on the pins you want to add. The pins will be assigned as pairs sequentially; normal windows 
functionality using shift or ctrl for multiple selections applies when selecting pins. 
 
 

Add 56 pins to the configuration by entering 55 in the pins value field and press the  button. 
Now 56 pins should have been added to the configuration.  

 

Figure 161161 Configure the FSMIT matrix 

Now add two hardware sub matrixes by pressing the  button twice. SMI 01 and SMI 02 should 
appear in the Sub Matrixes list box. 
Add the 28 first pins sequentially by selecting SMI 01 then select pin1 in the pins list box, now press 

shift and select pin28. Press the  button to assign the selected pins to SMI 01 
Use the same method as above to assign pin 29 to 56 to SMI 02. 

Add 56 
pins 

Add 2 
Sub 
Marixes 
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Select the Current feed dialog Figure 162162 and choose the Current feed 1 shown in the listbox. 
 

 
Figure 162162 Matrix current feed dialog 

 
Figure 163163 New FSM Matrix parameters 

 
Check the Set Current Automatically checkbox to make the FSM IT instrument automatically 
calculate the current after the download of the setup. (The instrument must be rebooted or tag 
reinitiated to effectuate the current calculation). Leave the other parameters to default. 
 
Save the configuration by choosing save on the file menu and then exit the pin configuration editor.  
 
Now you will return to the new matrix setup wizard. 
The items in the last parameters dialog, Figure 163163 ,in the wizard is optional. Press Finish when 
done. 
 
When the new matrix wizard is complete, the setup shall look like Figure 164164. 
 

 
Figure 164164 Complete Instrument Setup 

Matrix  

FSM IT 
Instrument 

Details 
Window 
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8.5.5.1 Configuring the SMI addresses 
To get the FSM IT instrument to recognise the matrix the SMI addresses must be entered, the 
address for each SMI + the reference SMI are found in the documentation for the delivery. The SMI 
address is also found stamped on the physical SMI itself. 
The address dialog is found in the details window for the matrix Figure 165165.  
Enter the supplied SMI addresses. 
 

 
Figure 165165 SMI adress dialog 

8.5.5.2  Transferring the setup to the instrument 
The instrument must be connected to the serial port, turn on the power for the FSM IT instrument by 
pressing the touch screen. Select the FSM IT instrument in MultiTrend, if the instrument has been 
used earlier on different sites, then select, the advanced commands button found in the commands 
dialog. In the advanced dialog, activate the Clean Sites button. Close the advanced commands and 
then activate the Send Setup button found in commands dialog. 

8.5.5.3 Setting the clock in the instrument 
To synchronise the instrument clock with the PC go to the status dialog found in the details window 
for the FSM IT instrument, activate the synchronise button.  

8.5.5.4 Starting a measurement from MultiTrend 
Start measurement button is found in the advanced commands dialog. 

8.5.5.5 Retrieving measurements  
Retrieve measurements are done from the commands dialog. 
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8.6 FSM IT Instrument Detail Dialogs 

8.6.1 Description dialog 

The description dialog is used to store general information about the instrument (user input). Editable 
in service and advanced service mode. 

8.6.2 Information dialog 

In the information dialog Part/Ser number, Order number, Manufacturer and installation date is found 
or can be entered if not already done in instrument installation dialog. Editable in service and 
advanced service mode 

8.6.3 Address dialog 

In the address dialog Figure 166166 the FSM IT reference SMI address is found. The FSM IT 
instrument uses the SMI reference serial to recognize what matrix it is physically connected to. The 
parameters that cannot be altered from this dialog must be altered from the address dialog for the 
matrix.  
 

 
Figure 166166 FSM IT Instrument address 
dialog 

 
Figure 167167 FSM IT Instrument commands 
dialog 

 

8.6.4 Commands dialog 

In the commands dialog Figure 167167 features for interacting and configuring the FSM IT 
instrument are found 
 
Automatic Measure: Not an available feature at the present time.  
 
Automatic retrieve: MultiTrend is configured to automatically retrieve data in online mode, available 
in service and advanced service mode. 
 
Measure before retrieve: MultiTrend starts a measurement before the automatic retrieve of data, 
available in service and advanced service mode. 
 
Apply to all loggers: Not usable for FSM IT instruments 
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8.6.5 Advanced commands 

The advanced commands dialog, Figure 168168 for the FSM IT instrument consist of two tree views 
where the local computer and the connected FSM IT instrument can be browsed for files and 
catalogs. 
The arrows between the two tree views are used to copy files back and forth between the instrument 
and the local computer.   
 
 

 
Figure 168168 Advanced Commands FSM IT Instrument 

• Start measurement: Start measurement on the FSM IT instrument from MultiTrend. 
Instrument must be turned on before command is sent. 

• Shutdown: Shutdown instrument from MultiTrend 
• Clean sites: Clean all matrices configured in the instrument. 
• View: View text or bbn files directly 

8.6.6 Communication options 

Communication options button opens the advanced Logger setup dialog, which is available in service 
and advanced service mode. In service mode the all parameters are read-only:  
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Figure 169169 Advanced logger setup 

In advanced mode the settings are available for editing: 
 

• Delay between commands: Time interval in milliseconds. Default value is 0. 
• Number of command retries: Determines how often MultiTrend attempts each 

communication command before flagging an error. Default value is 10. 
• Delay before command retries: Time interval in milliseconds. Default value is 3500. 
• Retrieve failures before logger reset: MultiTrend will attempt to restart the logger if 

communications fail on successive attempts. The default value is 20. 
• Clear Logger Memory After Retrieval: Deletes the measurements permanently in the 

logger, unmark command is not applicable if this option is checked. 
• Stop Retrieval After Failed Reset: If logger doesn’t respond after automatic logger reset 

MultiTrend deactivates the automatic retrieve function. 

8.7 FSM IT Matrix detail dialogs 

Same options as described for the G4 matrix in 8.4, except an additional address field where the 
addressing for the SMI’s are done. (Described in 8.5.5.1) 
 

8.8 FSM IT Matrix Sub Probes 

The FSM IT matrix has two sub probes 
 

• Housekeeping probe 
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• Temperature probe 
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9 IMPORT OF FSMTREND CONFIGURATIONS 
 
Import of FSMTrend configuration is available; the import dialog is started from the File Menu. 
To import a station or a FSMIT configuration select the directory containing the  
 FSMTrend configuration.  
 
MultiTrend will present the stations and sites found, Figure 170170, when the directory containing 
FSMTrend configurations is selected. 
Select the wanted configurations for import; several configurations can be imported at the same time.  
For stations, a pair configuration set-up is assumed based on the total pairs to create a database 
entry. The correctly pair definition must be uploaded from the physical station. For FSM IT the 
configuration is correct presented after import. No geometrical information is imported from the old 
configurations for either of the instruments. 
Only configurations from version FSMTrend 1.9 and upward can be imported. 
 

 
Figure 170170 FSMTrend Import Dialog 

10 DATA ANALYSIS 

10.1 Data handling 

FSM is primarily a metal loss monitoring system that measures general metal loss with an accuracy 
of 1/1000 of initial wall thickness. To prepare data for interpretation, the following functions are 
available:  

  
• Remove zero readings,  
• Temperature compensation 
• FSM-IT averaging 
• Offset compensation 
• Creating one metal loss curve from a group of pairs 
• Spike control 
• Smoothing filter 
• Groove analysis 
• Local Corrosion Analysis (LCA) 
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• Bend erosion compensation 
• Conversion to preferred output format  

 
MultiTrend performs all calculations without changing the raw data. See 10.4 for more information. 
 

10.1.1 FSM signature 

The signature is the basis, or reference value, for FSM data. All measurements are scaled relative to 
the signature. The signature is based on a series of measurements taken at a time when the wall 
thickness is known, often when the metal structure is new. The signature should be taken when the 
system is tuned and at normal operational (temperature) conditions.  
 
It happens that a new signature has to be set due to change of instrumentation or new measurement 
set-up parameters. This should not be done without supervision from CorrOcean personnel. 
 

10.2 How to edit and display pin pair groups in XYPlot 

This section explains how to generate a signature and to add or edit pin pair groups. All action to be 
taken in MultiTrend is written in bold. 

10.2.1 Generate signature 

To generate a new signature, choose a matrix and click on the commands tab in the details window. 
See Figure 171171. Click the 'Select Signature >>' button. The 'Select FSM Signature' window 
appears (Figure 172172).  
 

Choose
matrix

Here you
can
choose
new
signature

 
Figure 171171 Create new signature 
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Figure 172172 Create new signature dialog 

 
Name  Enter a name for the new signature. 

It is recommended to use a describing name, including the date, time and number of 
measurements for the signature. The name makes it easier to maintain several 
signatures! 
If you have generated several signatures, you can choose between them in the 
'Name of signature' list. 

 
Date & time Select the date and time for the start and end of the data interval to use for the 

signature. The number of included measurements is automatically updated in the 
'No. of meas.' field. 

 
Click OK to generate the signature. Click Cancel to not generate signature. 
 

10.2.2 FSM XYPlot 

To Start FSM XYPlot: 
 
1. Select the matrix you want to plot data from in the MultiTrend main window. Right click on the 

matrix, and a context menu will appear as in Figure 173173. Click on 'XYPlot'. The 'FSM data 
processing setup' window is displayed (Figure 174174). 

2. Select a data group to process. 
• Click the 'Signature…' button to choose between defined signatures. 
• Click the 'Interval…' button to select, add or edit a data interval to process. The default is to 

process all data. 
• Click the 'Setup…' button to calculate new temperature compensation factors (section 

10.4.2). 
• Click the 'Offset correction…' button to edit or add offset corrections (section 10.4.4). 
Press 'OK' to plot. The 'XYPlot' window appears (Figure 175175). 

3. To modify the plot, add a plot, open a new plot etc. use the toolbar (Figure 176176). 
4. To modify the data group plotted on the Y1/Y2 axis select 'Graph' and 'Dataset Y1' or 'Dataset 

Y2'. 
5. To add rates, select 'View' and 'Show'. Select 'Rates' to get the metal loss per year figure added 

to the legend. Select 'Rate graphs' to add a graph of the instant metal loss rate. For 'Rate 
graphs' you can select to get the rate over the last 7, 10, 30, 60 or 365 days. 

6. To toggle the unit of the x-axis, select 'View', 'X-axis' and choose between 'Timescale' or 
'Measurement number'. 
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Figure 173173 Start XY Plot or 3D Plot 

 
Figure 174174 Select data to process 

 
 

 
Figure 175175 XYPlot 
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Figure 176176 XYPlot toolbar 

 

10.2.3 Edit XYPlot groups 

To add a new data group, or adjust the settings for an existing data group, you must use the 'Edit 
groups' function. Tick off the 'Enable advanced settings' box in the 'FSM data processing setup' 
window (Figure 174174), and the 'Edit groups' pushbutton appears. Click the Edit Groups button. 
The window in Figure 177177 appears. 
 

 
Figure 177177 Group dialog 

 
Click the 'Add' button to add a new group.  
Select an old group and click the 'Delete' button to delete it. 
Select an old group and click the 'Properties' button to change its properties. 
Select an old group and click the 'Insert copy' button to get a copy of the group. 
 
If you want to 'Add' or change 'Properties', see 10.2.4 for information on changing data group 
properties. 
 
Click the 'Close' button when finished. 
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10.2.4 Change group properties 

 
                         Figure 178178 Processing Options 

When the 'Add' or 'Properties' button is pressed in the window in Figure 177177, the 'Data group 
properties' window (Figure 178178) appears. 
 
The 'Selected data' window shows which pin pairs that are included in the group. 
To add all available data to the selected data, click the Add all button. 
To add only one pair, select the pair in the Available data list, and click the Add button. As a 
shortcut you can double-click on the pair in the Available data list. 
 
To remove all selected data, click the Remove all button. 
To remove only one pair, select the pair in the Selected data list, and click the Remove button. As a 
shortcut you can double-click on the pair in the Selected data list. 
 
'Data processing options' are described in section 10.4 and 'Output format' is described in section 
10.5. 
 

10.3 Displaying data in 3D Plot 

In 3D Plot, all pin pairs are presented according to the matrix layout. Start 3D Plot by right-clicking on 
the matrix and selecting '3D plot' from the appearing context menu (Figure 173173). The 'Options' 
window (Figure 179179) will appear. 
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Figure 179179: Selecting processing options for 3D plot 

 
For 'Data processing options', it is referred to section 10.4. 
For 'Output format', it is referred to section 10.5.   
 
Click the 'Signature…' button to choose between defined signatures. 
Click the 'Interval…' button to select, add or edit a data interval to process. The default is to process 
all data. 
Click the 'Setup…' button to calculate new temperature compensation factors (section 10.4.2). 
Click the 'Offset correction…' button to edit or add offset corrections (section 10.4.4). 
 
Click the 'OK' button to plot. The 'FSM3DPlot' window appears (Figure 181181). 
 
Select 'File' and 'Setup…' to adjust axes, timesteps and processing options.. 
 
 

New plot

Copy

Bar plot
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Contour plot

Grid

Print
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Figure 180180: 3D Plot toolbar 
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Figure 181181: 3D Plot 

10.4 Description of the data processing options 

10.4.1 Remove zero readings  

If this option is checked, rawdata of value zero will be excluded from the data processing. 

10.4.2 Temperature compensation 

10.4.2.1 Temperature influence on FSM readings 
 
The electrical resistance in steel is a function of temperature. If the temperature in the monitored 
object increases by 10°C, the resistance will typically increase by 3% to 5% varying with the steel 
parameters.  
 
The reference bracket, made of the same steel material as the object, partially compensates for the 
temperature variations. The reference is thermally connected but electrically isolated from the 
measuring object. However, there will still be a temperature gradient between the object and the 
reference, which induces the need for temperature compensation. The temperatures of both the 
measuring object and the reference are measured. These temperatures are used by the MultiTrend 
temperature compensation algorithms.  
 
Uncompensated FSM data given as FC will vary linearly with the difference temperature (the 
difference between object temperature and reference temperature). For carbon steel monitored 
objects, the relation is approximately 2-3 FC per degree Celsius.  
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10.4.2.2 Difference temperature compensation 
 
This method compensates for variations in the FSM data that are correlated to variations in the 
difference temperature (the difference in temperature between the monitored object and the 
reference). Variability in the difference temperature is the major contributor to temperature variations 
in the FSM data.  
 

10.4.2.3 Spool temperature compensation 
 
This method compensates for variations in the data that are correlated to variations in the spool 
temperature. It may be used in cases where the measured values are correlated with the spool 
temperature rather than the difference temperature. This is rarely the case.  
 

10.4.2.4 Difference and spool compensation 
 
This method combines the two above compensation methods and can be useful when the 
temperature difference between the spool and reference is high, or if the materials in the spool and 
reference have different resistivity properties. 
 

10.4.2.5 Applying temperature compensation 
 
It is recommended to start with difference temperature compensation (DTC), since variability in the 
difference temperature is the major contributor to temperature variations in FSM data. The following 
procedure may be helpful when searching for the best data interval to use for calculation of 
temperature compensation factors: 
 
 

1. Study the relationship between measurement data and difference temperature: Make an 
XY-plot for one data group with default data processing options and add a new curve for 
the difference temperature in the same XY-plot. If there is a significant correlation 
between the measurement data and the difference temperature, DTC will likely produce 
good results. 

 
2. Calculate the difference temperature compensation factors: Click on the 'Setup' button in 

the 'FSM data processing setup' window (Figure 174174). Select 'Calculate difference 
compensation factors... '. The 'FSM data interval' window appears. Select the data 
interval that the compensation factors should be estimated from. It is recommended to 
use a relatively short interval with apparent correlation between the measured values and 
the difference temperature. A good interval comprises large temperature variations and 
stable temperature levels. Furthermore it should be short enough to assume no corrosion 
within the interval. Click the 'OK' button. Select a signature from the appearing 'Select 
signature' window. Remember that the signature should be set at normal temperature 
conditions (section 10.1.1). 

 
3. Activate difference temperature compensation from the 'Data group properties' window 

(Figure 178178). Tick off the checkbox for ‘Use temperature compensation’ and click the 
'Settings...' button to open the 'Temperature compensation settings' window. Make sure 
that only ‘Use difference compensation’ is selected/checked (Figure 182182). Click the 
'OK' button. 
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Figure 182182: Selecting type of temperature compensation 

 
4. View the compensated results: Make a new XY-plot by clicking on the 'OK' button in the 

'FSM data processing setup window'. In the next appearing windows click 'Close' and 
'OK'. Add the difference temperature for comparison. 

 
5. Change interval: Repeat pos. 2 to 4 with a new interval (experiment with start time and 

width) until the measured values no longer are significantly correlated with the difference 
temperature. 

 
6. When you are satisfied with the compensation to difference temperature, plot the spool 

temperature together with the compensated data. If there is a significant correlation, use 
the combined difference- and spool compensation. This requires that temperature 
coefficients for combining spool- with difference compensation are calculated. Follow the 
procedure under 2, but choose spool compensation factors. When asked whether to 
calculate compensation factors for combined compensation, answer 'Yes'. Follow 
procedure 3-5, and tick off both checkboxes in Figure 182182. 

 
7. To apply separate spool temperature compensation, the same procedure (2-5) as for 

difference temperature is followed (except to choose options associated with 'spool…' 
instead of 'difference…'). Tick off the 'Use spool compensation' checkbox in Figure 
182182.  

 
 

10.4.3 FSM IT Data averaging 

For FSM-IT instruments, measurement series of 3 or more measurements at a time are taken at 1-2 
weeks interval. The variations within a measurement series are normally not relevant when it comes 
to the long-term tendency.  Due to this fact, MultiTrend has an option to average measurements that 
are close in time and represent these with a single data value. 
 
To apply FSM IT averaging, tick off the 'FSMIT data averaging' box in the 'Data group properties' 
window (Figure 178178). Click the 'Settings' button, and select the averaging interval. 
Measurements can be averaged within intervals of 24 hours, 12 hours, 1 hour or 15 minutes. The 
time interval is stored in the groups.ini file as number of seconds, so other time intervals can be 
selected by editing the groups.ini file if necessary. 
 
The timestamp for the average of a measurement series is set to the time of the first measurement 
within the series. The average is calculated by combined mean and exclusion of outliers. 

10.4.4 Offset compensation 

When a circuit board or a station is changed, the measurements can get an offset due to the change 
of hardware. This can be compensated for by using the offset compensation in MultiTrend. Three 
offset compensation methods are available in MultiTrend (sections 10.4.4.1-10.4.4.3). 
 
To activate offset compensation, tick off the 'Use Offset compensation' box in the 'Data group 
properties' window (Figure 178178).  
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The 'Offset compensation list' defines what compensations that are performed, according to the 
entered compensations in the list. To edit the list click the 'Offset correction…' button in the 'FSM 
data processing setup' window (Figure 174174). The 'Offset compensation list' (Figure 183183) 
appears. All the compensations in the list will be applied to the data group when offset compensation 
is activated. 
 
Select 'Add offset' to add a new offset. 
Select 'Edit offset' to edit an existing offset. 
Select 'Delete offset' to delete an existing offset. 
 

 
Figure 183183: Offset compensation list 

If you choose to add a new offset, the 'Offset compensation' window (Figure 184184) appears. Give 
the new offset a name, preferably according to the date and time of the offset. Select what pairs that 
should be compensated. Hold down the <Ctrl> button to select more than one pair. Select what 
compensation method to use, described in sections (10.4.4.1-10.4.4.3). 
 

 
Figure 184184: Offset compensation 

 
Regardless of what compensation method you choose, when you click the 'Next' button, a window for 
entering the start time of the offset appears (Figure 185185). NOTE: The input start timestamp of the 
offset must be set in the time interval from the second last non-offset data point to the last non-offset 
data point (NB! Not including the timestamp of the second last data point, but including the 
timestamp of the last data point). 
 
Offset compensation includes establishing a new signature and a new baseline. The signature is 
calculated from data points after the offset. The user must choose how many data points to base the 
new signature on. For automatic compensation (section 10.4.4.1), the baseline is calculated from 
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data prior to the offset. In this case, the input number of data points for signature calculation also 
defines how many measurements the baseline is calculated from. 
 
 

 
Figure 185185: Enter start date and time for the offset and number of measurements in new 
signature. 

  

10.4.4.1 Automatic Compensation 
 
This method can be used when the metal loss rate is low. The new baseline is calculated as the 
median of the X last measurements before the offset. X is the same number of measurements that 
are used for signature calculation. 
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Figure 186186: Automatic Offset Compensation 

10.4.4.2 Manual Compensation  
 
This method can be used when the metal loss rate is low. The new baseline is entered manually 
(Figure 188188). Different values for each pair can be entered. 
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Figure 187187: Manual Offset Compensation 

 

 
Figure 188188: Enter new baseline for all pairs 

10.4.4.3 Rate-based Compensation 
 
This method is used when the metal loss rate is high. In addition to the median, the metal loss rate is 
calculated from a user specified interval before the offset (Figure 190190). With ∆t being the time 
interval between the last value before the offset and the first value after the offset, we get the 
following expression for the baseline: 
 
baseline = median + rate* ∆t 
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Figure 189189 Rate-based Offset Compensation 
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Figure 190190: Enter interval for rate-based offset compensation 

10.4.5 Create single metal loss curve from the mean of a group of pairs 

This processing option generates a single metal loss curve from the mean of the selected pin pairs. If 
more than 10 pairs are added to one data group, this setting is automatically selected. This option is 
activated by ticking off the 'Create single dataset from mean of selected data' checkbox in the 'Data 
group properties' window (Figure 178178). 

10.4.6 Spike control 

The spike control can be used to remove outliers in the dataset. Outliers are results of measurement 
noise, and typically occur as one or two data points with value far off from the trend in the dataset.  
The spike control is only designed to filter out spikes, or outliers, and let other artefacts, like ramps 
(signal offsets) and random noise, remain unaltered.  
 
The spike control is activated from the 'FSM data processing setup' window (Figure 174174). Tick off 
the 'Use spike control' box, and click the 'Settings' button. 
 
Three parameters configure the spike control: 'Amplitude threshold', 'Datapoints threshold' and 'Size 
of average buffer': 

• ' Amplitude threshold': The amplitude threshold is the maximum allowed signal step from 
one data point to the next. Make sure that this value is larger than the overall noise level. 
Allowed input is [1, 1000] ppt. 

• 'Datapoints threshold': The maximum number of subsequent data points that comprise a 
spike. A value of 1 or 2 is appropriate. This parameter also decides the time delay of the 
filter. 

• 'Size of average buffer': The length of the buffer of preceding measurements that serve as a 
basis for compensating the spike. If a data point is evaluated to be part of a spike, it is 
replaced by the average value of the data points in the buffer. The length of the buffer should 
be chosen to be relatively short (max. 10%) compared to the total number of data points. 
Allowed input is [4, 50].   

 

10.4.7 Filter 

MultiTrend comprises a smoothing filter for easier spotting of trends in FSM data series. The filter is 
a moving average filter, where each data point is replaced by the average of a buffer of preceding 
points. The length of the buffer decides the smoothness and time delay of the resulting data curve.    
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The filter is activated from the 'FSM data processing setup' window (Figure 174174). Tick off the 'Use 
filter' box, and click the 'Settings…' button. Set the parameter for 'Size of average buffer'. Allowed 
input is [4, 50]. 
 
The first n-1 data points, where n is the buffer size, is passed through without filtering. 

10.4.8 Groove (weld root) analysis 

Pipe welds are associated with localized corrosion. Application of analysis for general corrosion on 
weld root corrosion will give an under estimated corrosion depth. Hence, a special algorithm is 
developed for estimation of the depth of a uniform circumferential corroded groove. 
 
The groove analysis requires the following: 
 

- A group of pin pairs for groove analysis must be defined. This group must comprise the pairs 
covering the weld only. To do this, the layout of the FSM matrix must be available to the 
user. To learn how to define a group, see section 10.2.3. 

- The initial wall thickness of the pipe must be available in the database. The initial wall 
thickness is set in the 'FSM Pin Matrix Editor' (section 8.1.4/8.5.4).  

 
To apply groove analysis: Enter the 'Data group properties' window (Figure 178178). Check the 'Use 
groove analysis' box, and enter the corresponding 'Settings…' menu. Enter the pin-pin distance 
and the expected width of the groove, both in mm. The width of the groove can be assumed to be 
equal to the width of the weld, and must lie in the interval (1/3, 2/3)*WT, where WT is the initial wall 
thickness of the pipe. 
 

 
Figure 191191 Groove analysis settings 
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10.4.9 LCA Analysis 

Local Corrosion Analysis is an algorithm developed for quantification of pitting corrosion. The 
analysis is optimised for pits the size of one pin quadrant (the area in between 4 pins). 
 
To use LCA analysis, the following is required: 

• The 'pair_lay.out' configuration file must be defined and stored in the stations subfolder 
of the MultiTrend folder. Furthermore, the defined pair layout must be a continuous area, 
where all pair rows are of equal length 

• The initial wall thickness of the pipe must be available in the database. The initial wall 
thickness is set in the 'FSM Pin Matrix Editor' (section 8.1.4/8.5.4).  

• In the Station.ini file, the line 'DoLCAAnalysis=1' must be added under the '[Data 
Processing Settings]' section. 

 
To apply LCA: Enter the 'Data group properties' window (Figure 178178). Check the 'Use LCA 
analysis' box, and enter the corresponding 'Settings…' menu.  
 

 
Figure 192192 LCA Analysis Properties 

A number of parameters define the LCA: 
 

• 'Max L': The number of pin-pairs in the current direction. 
• 'Max K': The number of pin-pairs in the direction normal to the current. 
• The 'Pits along the edges' option allows corrosion elements to be removed on a frame 

outside the pin-matrix. 
• 'Use initial start values': Tick this box off to require continuous time series. 
• 'Maximum number of iterations', typically between 200 and 400. 
• 'Stepwise increase in depth'. This parameter defines the depth resolution in the analysis, a 

typical value is 0,0001 mm. 
 
To do an analysis optimised for pits the size on quarter of a pin quadrant, tick off the checkbox for 
enabling 'Fine analysis'. Fine analysis is applied to a subsection of the matrix defined by L 
lower/higher and K lower/higher. The lower/higher values point to the pin quadrants, as shown in 
Figure 193193. 
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NOTE: At present, LCA is not released for common users. LCA is password protected. 
 
 

Figure 193193: Defining a subsection for fine analysis. Example 1 (Blue): L lower = 1, L 
higher = 2, K lower = 1, K higher = 1. Example 2 (Red): L lower = 3, L higher = 4, K lower = 
1, K higher = 2. Example 3, whole matrix: L lower = 1, L higher = 4, K lower = 1, K higher = 
2. 
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10.4.10 Compensation for bend erosion 

Erosion damages in bends can occur whenever sand is mixed into the fluid flow. The damages will 
typically be oval-shaped wear along the outer elbow of the bend. The damages vary in curvature, 
depth, length and width depending on the qualities of the mixed flow. Since the damages are not 
uniform around the circumference of the pipe, we need a special application for compensation of 
metal loss depth in erosion damages.  
 
The bend compensation application should only be used where bend erosion is expected. To ensure 
that only significant signal increases are compensated for, only data points higher than 5 ppt are 
considered. 
 
Stepwise description: 
 

1. Enter the 'Data group properties' window (Figure 178178). Check the 'Bend Erosion 
Compensation' box. 

2. Push the 'Settings…' button and enter expected width and length of the erosion damage. 
Allowed width interval is 28°-180° (out of 360° circumferential). Allowed length interval is 10°-
90° (out of a 90° bend). 

 
 

 
                    Figure 194194: Dialog box for input parameters to bend compensation 

 
Please Note: 

1. If the resulting corrected depth is higher than 400 ppt, the calculated value is an upper limit. 
400 ppt is the lower limit. 

2. If the resulting corrected depth is less than 50 ppt, the calculated depth is a lower limit. 50 
ppt is the upper limit. 

 

10.5 Output format 

Four output formats are available for XYPlot: 
 
[ppt]  Relative measure, parts per thousand of initial wall thickness 
[mm]  Absolute measure, metal loss depth in mm = 10-3 m  
[mils]  Absolute measure, metal loss depth. 1 mil = 0.001 in = 0.0254 mm = 2.54*10-5 m 
[µm]  Absolute measure, metal loss depth in µm = 10-6 m 
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11 GETTING SUPPORT AND SENDING US FEEDBACK 
 
If you need technical support on installing or using the MultiTrend program, or you want to give us 
feedback on any features that you like, dislike or want to see in upcoming versions of the software, 
please contact the CorrOcean main office or one of our subsidiary offices either by mail, e-mail, fax 
or phone. Customer support email address: support@corrocean.no 
 

11.1 Technical Support 

 
If you are requesting technical support, please make sure to include the following information in your 
request: 
• MultiTrend version (Shown in the MultiTrend About window) 
• The operating system and version you are using 
• The type of PC you are using (CPU type, amount of RAM and disk size) 
• The communication settings on your PC (COM-port number, modem type etc.) 
• The type of equipment you are accessing with the program 

mailto:support@corrocean.no
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Main Office: 

 

CorrOcean ASA 
Teglgården 
7005 TRONDHEIM 
NORWAY 
 

Phone +47 7382 5000 
Fax +47 7382 5050 
e-mail mail@corrocean.no 
 
CorrOcean ASA, Teglgarden, N-7485 Trondheim, Norway, phone: +47 73 82 50 00, fax: +47 73 82 50 50 

CorrOcean Inc, 3300 Walnut Bend Lane, Houston Texas 77042, USA, phone: +1 713 334 2222, fax: +1 713 266 0172 

CorrOcean Srl, Via Tiburtina 1470, 00131 Rome, Italy, phone: +39 06 4129 4201, fax: +39 06 4129 4288 

 
 
 
Also, if you have Internet access, please feel free to visit us at the following World Wide Web 
address: http://www.corrocean.no 
Here you can find information about CorrOcean and the products and services we can offer. 
 

mailto:mail@corrocean.no
http://www.corrocean.no
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